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Exchange Recipient Update Service fails to process accounts and MSExchangeAL 8151 event logged


View products that this article applies to.

Symptoms

The Microsoft Exchange 2000 Server and Microsoft Exchange Server 2003 Recipient Update Service (RUS) may not stamp proxy addresses on Active Directory objects. Also, the following event may appear in the Application Log of the Event Viewer:
Event Type: Warning
Event Source: MSExchangeAL
Event Category: Service Control
Event ID: 8151
Description: Cannot read service configuration. Retry after 1 minute.
When you try to resolve the mailbox name of a new mailbox with Microsoft Outlook, the name or the alias is not resolved, and you receive the following error message:
The name could not be resolved. The name could not be matched to a name in the address list.
Additionally, the mailbox may not appear when you look for it in the Global Address List.

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Cause

This problem may occur if the Exchange Server name that is specified in the Properties dialog box of a Recipient Update Service instance is missing or is incorrect.

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Resolution

To resolve this problem, specify an Exchange Server for the domain or enterprise configuration Recipient Update Service. To do this, follow these steps:
  1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
  2. Double-click Recipients, and then click Recipient Update Services.
  3. In the right pane of the Exchange System Manager window, right-click Recipient Update Service (Enterprise Configuration), and then click Properties.
  4. Verify that a valid Exchange server name appears in the Exchange server box. If the server name does not appear, or if the one that appears is incorrect, click Browse. In the Select Exchange Server dialog box, click a valid Exchange server in the site, click OK, and then click OK again.
  5. In the right pane, right-click Recipient Update Service (Enterprise Configuration), and then click Rebuild.
  6. Click Yes to confirm the rebuild operation.
  7. In the right pane of the Exchange System Manager window, right-click Recipient Update Service (domain), where domain is the name of your domain, and then click Properties.
  8. Verify that a valid Exchange server name appears in the Exchange server box. If the server name does not appear, or if the name that appears is incorrect, click Browse. In the Select Exchange Server dialog box, click a valid Exchange server in the site, click OK, and then click OK again.
  9. Right-click Recipient Update Service (domain), where domain is the name of your domain, and then click Rebuild. Click Yes to confirm the rebuild operation.
  10. Right-click Recipient Update Service (domain), where domain is the name of your domain, and then click Update Now.
  11. Quit the Exchange System Manager.

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More information

For additional information about the Recipient Update Service, click the following article numbers to view the articles in the Microsoft Knowledge Base:
253770 Tasks performed by the Exchange Recipient Update Service
286356 Recipient Update Service does not stamp proxy addresses

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Keywords: KB322313, kbprb

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Article Info
Article ID : 322313
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 632