Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Directory synchronization from Exchange 2000 to a foreign mail system fails in Exchange 2000


View products that this article applies to.

This article was previously published under Q321287

↑ Back to the top


Symptoms

When you try to run directory synchronization from Exchange 2000 or Exchange 2003 to a foreign mail system by means of an Exchange foreign mail connector, Exchange updates may not synchronize to the foreign mail system.

The foreign mail connectors that are affected are:
The Microsoft Exchange Connector for Lotus Notes
The Microsoft Exchange Connector for Novell GroupWise
The Microsoft Exchange Connector for Lotus cc:Mail
The Microsoft Mail Connector
No error messages are logged in the Application event log or the Conndata log on the server. The only event message that is logged is a confirmation message that states that directory synchronization is complete. This message is similar to:
Event ID: 60378
Source: MSExchangeNOTES
Type: Information
Description:
Directory Synchronization Export is complete. MS.DXAMEX successfully exported 0 entries, and had problems exporting 0 entries.

↑ Back to the top


Cause

This issue may occur if Exchange queries a global catalog server for the Exchange updates, but the global catalog server is unavailable or no longer exists.

When the first directory synchronization cycle for a foreign connector is complete, the connector must send a list of Exchange objects. These objects are in the organizational unit that is specified on the Export tab in the properties of the connector. The connector creates this list of users by contacting a global catalog server to obtain this information. All of the other directory synchronization cycles also try to contact the same global catalog server from that point on.

The global catalog server that the connector tries to contact to obtain updates is stored in the msExchServer1NetworkAddress attribute. After the msExchServer1NetworkAddress attribute is set in Active Directory, the msExchServer1NetworkAddress attribute is not changed, no matter what changes are made to the network topology.

NOTE: Slow directory synchronization may also occur if this value is set to a global catalog server that does not exist locally, or a global catalog server that is not available over a wide area network (WAN) link. During a directory synchronization export, the connector may try to contact a global catalog server that is remote. This may slow the process.

↑ Back to the top


Resolution

To resolve this issue, identify the global catalog server that the connector is trying to contact for updates, and then change the msExchServer1NetworkAddress attribute to reflect the name of a working (or local) global catalog server. This data is in the msExchServer1NetworkAddress attribute for these connectors in Active Directory.

Use ADSI Edit (in the Microsoft Windows 2000 Support Tools on the Windows 2000 Server CD) to change the msExchServerServer1NetworkAddress attribute on the connector.

WARNING: If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Exchange 2000 Server, or both. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

To use ADSI Edit to change the msExchServerServer1NetworkAddress attribute on the connector:
1.Start ADSI Edit, and then locate the connector that is experiencing the directory synchronization issue. Expand the Configuration folder, expand the Services folder, and then expand the Microsoft Exchange folder. Expand the Domain folder, expand the Administrative Groups folder, expand the First Administrative Group folder, expand Routing Groups, expand First Routing Group, and then expand Connections.
2.Locate the connector on the preview side, and then right-click the connector to open its properties.
3.In the Select which properties to view list, click Both.
4.In the Select a property to view list, click msExchServer1NetworkAddress.
5.In the Value(s) box, the server name of a global catalog server is listed. If this server is not a global catalog server, or is not a functioning global catalog server, you have to modify this attribute.
6.In the Edit Attribute box, type the server name of a global catalog server (the closest global catalog server is fine), and then click Set, so that the new global catalog server name is displayed in the Value(s) box.
In order for the change to take effect, you have to restart the affected service in the Services control panel. You must then perform an Immediate full reload from Exchange to Lotus Notes or Novell GroupWise. To do so, click the Dirsync tab in the properties of the connector in Exchange System Manager. For the Microsoft Mail for PC Networks connector, the changes will take effect during the next directory synchronization, or you may have to do a manual directory synchronization. Microsoft Exchange Connector for Lotus cc:Mail may require another directory synchronization cycle.

↑ Back to the top


More information

For additional information about the Conndata logs, and how to increase logging for the foreign connectors in Exchange 2000 for troubleshooting, click the article number below to view the article in the Microsoft Knowledge Base:
269040 XFOR: How to Use Lsadmin.exe on Exchange 2000 Server
295307 XFOR: How to Enable and Increase Logging for MECC Connectors

↑ Back to the top


Keywords: KB321287, kbprb

↑ Back to the top

Article Info
Article ID : 321287
Revision : 6
Created on : 2/28/2007
Published on : 2/28/2007
Exists online : False
Views : 468