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A fully applied document is still in open status in Payables Management


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Symptoms

When reviewing the Aged Trial Balance report or Historical Aged Trial Balance (HATB) report in Payables Management, a document shows up as fully applied and is still in the open table. I should have moved to history automatically. How do I get the document to move to history now?

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Cause

Fully applied document where the Amount Remaining is $0.00 should automatically move to history during the posting process. If it did not, there is data corruption.

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Resolution

Please review these steps:

1. In Microsoft Dynamics GP, go to Inquiry, click on Purchasing and click on Transaction By Vendor. Click to unmark the WORK and HISTORY checkboxes and click Redisplay to view documents only in OPEN status. 

NOTE: Use the View | Currency | Functional to view the document in Functional Currency.

2. Click to expand the line, and review all open documents. Locate the problem document. If the Unapplied Amount is $0.00, it is fully applied (which is the CURTRXAM field in the PM20000 table.)   

3. Next, click to select/highlight the problem document and click on the Unapplied Amount link to drill back to view the records applied against it. Verify that the total of the Applied Amount field for all the apply records adds up to the total amount of the document to verify that it is fully applied. 

If not and there should be dollars left on it to apply to, then update the CURTRXAM field in the PM20000 table for the amount that should still be unapplied on the document. 

4. If the applied records match the total document amount and the document should be in history, you can go to Microsoft Dynamics GP, point to Maintenance and click on Check Links. Select the Purchasing series. Insert over the Payables Transaction Logical File and click OK. Check links should move all document in the open table with an amount remaining of 0.00 to history.

**IMPORTANT NOTE: You are not able to 'in-do' check links, so make sure to have a current backup first, or do this in a test company first to review what it all did and to make sure you agree before you run this on your live database, to prevent any surprises.**

5.  Review in Purchasing Inquiry to see if the document has now moved to history. 

6. If not, then use the scripts below to locate the remittance records for it in the PM20100 table, and delete these records. The PM20100 remittance table is just a table that stores apply records solely for the purpose of printing them on the next check stub sent to the vendor (if you are printing previously applied documents). Once the records are printed, they are removed from this remittance table, or just build in this table if they are not printed. This record may hold it up from moving to history and does not hurt anything to remove this record. Delete it from the PM20100 remittance table once you have located it. Below are helpful scripts to use to locate it in this table.
select * from PM20100 where VENDORID = 'xxx' and DOCDATE = '2017-04-12'
--update the vendor ID and the document date for the problem document to help locate it.

Delete PM20100 where DEX_ROW_ID = X
--update the script for the dex row ID you with to remove.

7. After deleting the remittance document from the PM20100 table, then run check links again and it should move to history now. (See step 4.)

8. Review in Purchasing Inquiry again to verify the document has now moved to history.



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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 3208146
Revision : 1
Created on : 1/7/2017
Published on : 11/28/2016
Exists online : False
Views : 281