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A security policy does not process restricted groups correctly


View products that this article applies to.

Symptoms

If you configure a restricted group by using Group Policy, the membership list is incomplete when the group is processed by the client. This problem is indicated by events from the SceCle and Userenv sources in the application event log. For example:
Event Type: Warning
Event Source: SceCli
Event Category: None
Event ID: 1202
Date: 4/29/2002
Time: 12:58:58 PM
User: N/A
Computer: PTV2000S
Description:
Security policies are propagated with warning. 0x428 : An exception occurred in the service when handling the control request.
Please look for more details in TroubleShooting section in Security Help.

Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1000
Date: 4/29/2002
Time: 12:58:58 PM
User: NT AUTHORITY\SYSTEM
Computer: PTV2000S
Description:
The Group Policy client-side extension Security was passed flags (17) and returned a failure status code of (1064).
You can identify the restricted group that is causing the problem by viewing the Winlogon.log file that is created. To do this, you must turn on SceCli debugging. For additional information about how to turn on debug logging, click the following article number to view the article in the Microsoft Knowledge Base:
245422 How to enable logging for Security Configuration Client processing in Windows 2000
In some cases, after the problem occurs, there is no additional processing of any security policy until you resolve the issue.

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Cause

This problem is triggered when a user object that has been configured to be a member of a restricted group is deleted from Active Directory.

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Resolution

Microsoft Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows 2003 Server, 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Feb-2004  01:46  5.2.3790.132      324,096  Scesrv.dll       
   20-Jan-2004  00:54                        271  Branches.inf
   21-Feb-2004  04:25                      9,766  Kb320099.cat
   21-Feb-2004  01:52                        354  Updatebr.inf
   21-Feb-2004  01:52                      6,255  Update_rtmqfe.inf
Windows Server 2003, 64-Bit Edition
   Date         Time   Version       Size     File name        Platform
   --------------------------------------------------------------------
   21-Feb-2004  01:52  5.2.3790.132  782,848  Scesrv.dll       IA-64
   20-Jan-2004  00:53                    271  Branches.inf
   21-Feb-2004  04:25                  9,766  Kb320099.cat
   21-Feb-2004  04:19                    354  Updatebr.inf
   21-Feb-2004  04:19                  6,275  Update_rtmqfe.inf

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP Professional, 32-bit version
   Date         Time   Version        Size     File name
   --------------------------------------------------------------
   26-Jan-2004  17:49  5.1.2600.1335  309,760  Scesrv.dll       
Windows XP Professional, 64-bit edition
   Date         Time   Version        Size     File name   Platform
   -----------------------------------------------------------------
   26-Jan-2004  17:43  5.1.2600.1335  855,040  Scesrv.dll  IA-64

Windows 2000 service pack information

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to obtain the latest Windows 2000 service pack

File information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   19-Apr-2002  21:22  5.0.2195.4959  123,664  Adsldp.dll
   30-Jan-2002  02:52  5.0.2195.4851  130,832  Adsldpc.dll
   30-Jan-2002  02:52  5.0.2195.4016   62,736  Adsmsext.dll
   19-Apr-2002  21:22  5.0.2195.5201  356,624  Advapi32.dll
   19-Apr-2002  21:22  5.0.2195.5595  135,952  Dnsapi.dll
   19-Apr-2002  21:22  5.0.2195.5595   96,016  Dnsrslvr.dll
   19-Apr-2002  21:22  5.0.2195.5246  145,680  Kdcsvc.dll
   23-Mar-2002  01:50  5.0.2195.5246  199,952  Kerberos.dll
   07-Feb-2002  21:35  5.0.2195.4914   71,024  Ksecdd.sys
   07-Apr-2002  02:13  5.0.2195.5544  503,568  Lsasrv.dll
   07-Apr-2002  02:14  5.0.2195.5544   33,552  Lsass.exe
   08-Dec-2001  02:05  5.0.2195.4745  107,280  Msv1_0.dll
   19-Apr-2002  21:22  5.0.2195.4917  306,960  Netapi32.dll
   19-Apr-2002  21:22  5.0.2195.4979  360,208  Netlogon.dll
   19-Apr-2002  21:22  5.0.2195.5561  917,264  Ntdsa.dll
   19-Apr-2002  21:22  5.0.2195.5585  386,832  Samsrv.dll
   30-Jan-2002  02:52  5.0.2195.4874  128,784  Scecli.dll
   19-Apr-2002  21:22  5.0.2195.5615  299,792  Scesrv.dll
   19-Apr-2002  21:22  5.0.2195.5525   48,400  W32time.dll
   03-Apr-2002  02:51  5.0.2195.5525   56,592  W32tm.exe
   19-Apr-2002  21:22  5.0.2195.5011  125,712  Wldap32.dll 

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Workaround

To work around this problem, remove the orphaned security identifiers (SIDs) from the list of accounts that are to be configured by using Group Policy for the affected group.

If security policy processing stops working completely because of this problem, the workaround is not effective until you restart the computer.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

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More information

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server product
For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:
296861 How to install multiple Windows updates or hotfixes with only one reboot

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbbug, kbfix, kbsecurity, kbwin2000sp3fix, KB320099

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Article Info
Article ID : 320099
Revision : 8
Created on : 8/29/2007
Published on : 8/29/2007
Exists online : False
Views : 511