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XADM: You Are Unable to Create Mail-Enabled Contacts on a Workstation


View products that this article applies to.

This article was previously published under Q320073

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Symptoms

If you use Active Directory Users and Computers to create mail-enabled users or Contacts on a workstation that Exchange System Manager is installed on, you may receive the following error message:
An Exchange Server could not be found in the domain.
Check if the Microsoft System Attendant service is running on the Exchange Server.

ID no: c10308a2
Microsoft Active Directory - Exchange Extension
You may also receive the following remote procedure call (RPC) error message:
The RPC server is unavailable.
Facility: Win32 ID no: c00706ba
NOTE: If you create mailbox-enabled users or non-mail enabled users or Contacts, Active Directory Users and Computers works correctly.

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Cause

This behavior may occur if:
The Microsoft Exchange System Attendant service is not running on any server in the administrative group. -or-

File and printer sharing is disabled on all of the Exchange servers in the administrative group. -or-

You cannot contact any of the Exchange servers in the administrative group by using RPC from the workstation. This cause may be related to networking, Windows Internet Naming Service (WINS), or Domain Name System (DNS).

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Workaround

To work around this behavior, make sure that the Exchange System Attendant service is running and file and printer sharing is enabled on at least one Exchange server in the administrative group. Also make sure that you can connect to a file share on that same Exchange server from the workstation.

To work around this behavior if file and printer sharing is disabled, you can create mail-enabled users or Contacts on the Exchange server itself if the System Attendant service on that Exchange server is running.

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Status

This behavior is by design.

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More information

When you create mail-enabled users or Contacts on a workstation, file and printer sharing must be enabled on the Exchange server so that the server can make sure that the e-mail address that you give the Contact is unique in the forest.

Mail-enabled users and Contacts have e-mail addresses associated with them. Mailbox-enabled users are users with Exchange mailboxes.

When you create mailbox-enabled users, you do not receive the error message in the "Symptoms" section of this article. This is because the Recipient Update Service that is running on an Exchange server in the System Attendant service is responsible for assigning e-mail addresses to the mailbox-enabled users and verifying that they are unique.

The Recipient Update Service assigns and checks e-mail addresses after you create the user; therefore; you do not receive the error message when you create a mailbox-enabled user.

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Keywords: KB320073, kbprb, kberrmsg

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Article Info
Article ID : 320073
Revision : 6
Created on : 2/28/2007
Published on : 2/28/2007
Exists online : False
Views : 213