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Farspace.sys driver is incompatible with Windows 10 Anniversary Update (version 1607)


View products that this article applies to.


Are you running Windows 10 Anniversary Update (Version 1607)?
  • Type “winver” in the Cortana text field on your taskbar.
  • The resulting window will indicate what version and OS build your system is running.

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Symptoms


After you upgrade to Windows 10 Anniversary Update (version 1607), the device crashes shortly after startup and returns the following error: 

IRP_NO_MORE_STACK_LOCATIONS

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Cause

This problem may occur when a specific third-party driver (farspace.sys) is installed on the system before you upgrade to Windows 10 Anniversary Update (version 1607). If a computer that has the unsupported driver is upgraded, an "IRP_NO_MORE_STACK_LOCATIONS" bugcheck error is triggered. Farspace.sys driver versions 8.34.x.4642 and earlier are known to cause this problem.

Note If you have not yet upgraded to version 1607 and have the 8.34 (or earlier) driver installed, installing the updated version through this KB article or through Faronics Support will provide a much smoother upgrade experience.

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Resolution

A fixed version of the driver is available and can be installed by using the following download package:

http://download.microsoft.com/download/E/3/F/E3F08DA5-797F-4F13-88E2-D7F8A497C907/DeepFreeze Win10 FarSpace Patch.msi

Note This fix is a third-party binary provided by Faronics. Support and any future updates will come from Faronics. Microsoft does not maintain this code and does not in any way guarantee security, reliability, or compatibility of this code. All issues with this fix must be addressed to Faronics.

Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.



To verify that the issue on your system is caused by this driver, follow these steps:
  1. Navigate to the C:\Windows\System32\drivers folder.
  2. Locate the farspace.sys file.
  3. Right-click the file, and then click Properties.
  4. In the properties window, select the Details tab, and note the file version.
  5. If the file version is 8.34.x.4642 or earlier, this driver is causing this error.
If this driver version is installed on your system, download the following package, and then install the updated driver:

To make sure there’s sufficient time to install the updated driver, follow these steps:
  1. Disable a scheduled task that's triggering the faulty code.
  2. Install the updated driver.
  3. Re-enable the scheduled task.
Note The system must be booted in a thawed state (suspended deep freeze) for the following changes to take effect.

How to disable the Storage Sense scheduled task

  1. At an elevated command prompt, press the Windows Key + X, press A, and then accept the elevated command prompt.
  2. Type schtasks /Change /TN Microsoft\Windows\DiskFootprint\StorageSense /DISABLE, and then press Enter.

How to enable the updated driver

Download the package in this KB, navigate to its download location, launch the update package (“Deep Freeze Win10 FarSpace Patch.msi”) and follow the on-screen instructions.

Re-enable Storage Sense

  1. At an elevated command prompt, press the Windows Key + X, press A, and then accept the elevated command prompt
  2. Type schtasks /Change /TN Microsoft\Windows\DiskFootprint\StorageSense /ENABLE, and then press Enter.

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Keywords: kbqfe, kbsurveynew, kb

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Article Info
Article ID : 3199223
Revision : 1
Created on : 1/7/2017
Published on : 11/11/2016
Exists online : False
Views : 957