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“Operation failed. Cannot query rows in a table” error during FindItems operation in EWS in Exchange Server 2016


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Symptoms

In a Microsoft Exchange Server 2016 environment, users experience the following behavior when a FindItems operation is performed in Exchange Web Services (EWS) calls:
  • The EWS call fails with the following error:

    Unhandled Exception: Microsoft.Exchange.WebServices.Data.ServiceResponseException: An internal server error occurred. The operation failed., Cannot query rows in a table.
  • The EWS logs in C:\Program Files\Microsoft\Exchange Server\V15\Logging\Ews on the mailbox role server show the following error:

    ExceptionHandler_Execute=Microsoft.Exchange.Data.Storage.StoragePermanentException: Cannot query rows in a table. ---> Microsoft.Mapi.MapiExceptionMaxObjsExceeded: MapiExceptionMaxObjsExceeded: Unable to query table rows.

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Cause

A change in the number of materialized restrictions that can exist in a mailbox was introduced in Exchange Server 2016. This change may trigger a situation where a FindItems call must create a new materialized search in the mailbox but cannot do so because the mailbox is already at the limit.

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Resolution

To resolve the issue, install Exchange Server 2016 Cumulative Update 3 or later. In the scenario that's described in the "Symptoms" section, the oldest materialized search will be aged out after you install this update. Therefore, a new search can be created without generating an exception.

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Keywords: kb, kbsurveynew

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Article Info
Article ID : 3196521
Revision : 2
Created on : 7/30/2020
Published on : 7/30/2020
Exists online : False
Views : 441