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Error -613 message and you cannot back up Exchange 2000 Server or Exchange Server 2003


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Symptoms

When you try to perform an online backup of the Microsoft Exchange Storage Group or of a single mailbox or public folder store, the operation may fail and the program event log may display events similar to the following events:
Event Type: Information
Event Source: NTBackup
Event Category: None
Event ID: 8000
Description: Begin Backup of 'MAILMASTER\Microsoft Information Store\'First Storage Group' Verify: Off Mode: Append Type: Normal

Event Type: Information
Event Source: ESE
Event Category: (3)
Event ID: 210
Description: Information Store (1812) e85d4e03-5bb3-44c5-bd2f-1343972a1b1a: A full backup is starting.

Event Type: Information
Event Source: ESE
Event Category: (3)
Event ID: 220
Description:
Information Store (1812) e85d4e03-5bb3-44c5-bd2f-1343972a1b1a: Beginning the backup of the file D:\Programme\Exchsrvr\mdbdata\priv1.stm (size 2850 Mb).

Event Type: Error
Event Source: ESE
Event Category: (3)
Event ID: 478
Description:
Information Store (1812) The streaming page read from the file "D:\Programme\Exchsrvr\mdbdata\priv1.stm" at offset 693297152 (0x000000002952e000) for 4096 (0x00001000) bytes failed verification due to a page checksum mismatch. The expected checksum was 3505519770 (0xd0f1fc9a) and the actual checksum was 3505518746 (0xd0f1f89a). The read operation will fail with error -613 (0xfffffd9b). If this condition persists then please restore the database from a previous backup.

Event Type: Error
Event Source: ESE
Event Category: (3)
Event ID: 217
Description:
Information Store (1812) e85d4e03-5bb3-44c5-bd2f-1343972a1b1a: Error (-613) during backup of a database (file D:\Programme\Exchsrvr\mdbdata\priv1.stm). The database will be unable to restore.

Event Type: Information
Event Source: ESE
Event Category: (3)
Event ID: 222
Description:
Information Store (1812) e85d4e03-5bb3-44c5-bd2f-1343972a1b1a: Ending the backup of the file D:\Programme\Exchsrvr\mdbdata\priv1.stm. Not all data in the file has been read (read 693239808 bytes out of 2988449792 bytes).

Event Type: Error
Event Source: NTBackup
Event Category: None
Event ID: 8012
Description:
The 'Microsoft Information Store' returned error from ESE function call (d).from a call to 'HrESEBackupRead additional data

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Cause

This issue occurs because of hardware-related issues on the Microsoft Exchange 2000 Server or Microsoft Exchange Server 2003 computer or because of issues with the third-party applications that are installed on the Exchange 2000 or Exchange 2003 computer. In certain database operations, including but not limited to online backup, the backup routine makes a call to the operating system to read a 4-KB page of data from the database on disk and write the data to tape. Before the online backup process writes the data that is returned from the operating system call to the tape, the online backup process compares the checksum value in the page header (recorded when this page was written to disk) to that being returned from the READ call. If the checksum values do not match, the Exchange database engine detects this and returns the error -613.

Error -613 translates to JET_errSLVReadVerifyFailure (checksum error in SLV file during backup, where "SLV" stands for "streaming" or ".stm" file).

Error -613 (JET_errSLVReadVerifyFailure) is similar to error -1018 (JET_errReadVerifyFailure). Exchange 2000 or Exchange 2003 logs error -613 for checksum errors on the .stm database file and logs error -1018 for checksum errors on the .edb database file. For additional information about the underlying cause of these errors, click the following article number to view the article in the Microsoft Knowledge Base:
314917 XADM: Understanding and analyzing -1018, -1019, and -1022 Exchange database errors


Under certain conditions, third-party applications can cause this issue to occur in the streaming file (.stm) in the database.

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Resolution

To resolve this issue, first determine if the issue is caused by hardware-related issues or issues with the third-party applications. If the issue is caused by hardware-related issues, first determine the root cause of the corruption. To do so, check the system log, run chkdsk and perform other diagnostic tasks. If you do not determine and fix the root cause of the -613 error, the corruption problem may occur again, even if you repair the databases or restore the databases from a backup.

To perform a successful backup, use one of the following methods:
  • Restore the information store from the previous online backup.
  • If the mailbox store is affected and you have an Enterprise version of Exchange 2000 or Exchange 2003, move the mailboxes to another server or mailbox store.
  • If the public folder store is affected, replicate the content of the public folders to another server.

    This type of corruption is not moved to a new store or server when you move the mailboxes to the new store or server. However, checksum errors can cause the move process to fail for the mailboxes that have data in affected database pages. Use the Outlook Import and Export wizard or the Exmerge process to download the contents of any mailboxes that fail the Move Mailbox process to a PST file. The same information applies to public folders and items in public folders.

    After you have moved all of the data out of the database, you can delete the damaged but now empty store *.edb and *.stm files or move them out of the folder where they exist. New .edb and .stm files are created when you mount the empty store. After you have finished this process, you can move the users or public folders back to the original server.

    Note To prevent the recurrence of any corruption problems, you must determine the root cause of checksum errors before you move the users or public folders back to the original server.

  • To repair the corruption in database pages if you do not have a valid backup and you are running the standard version of Exchange 2000 or Exchange 2003, run the eseutil /p command, run the eseutil /d command, and then run the isinteg -fix command on the affected store.

    Caution After you make repairs to the database by using the eseutil /p switch, the database may not be stable and reliable. Because the repair process deletes database pages, data loss is likely.
Note If you have to run a hard repair on your production database, Microsoft recommends that you move the data out of the repaired database to a new database or rebuild the database. For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
259688 XADM: How to use the Exmerge utility to extract data from a damaged private information store
259851 Ramifications of running the eseutil /p or edbutil /d /r command in Exchange
219419 Information store stops unexpectedly and cannot be repaired


If the issue is related to third-party applications, contact the third-party company.

For information about how to contact the third-party company, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:
65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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Keywords: KB318429, kbprb

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Article Info
Article ID : 318429
Revision : 7
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 378