Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Error.AspNetInstallPath.Exception" error when configuring Microsoft Dynamics CRM for Microsoft Office Outlook


View products that this article applies to.

Symptoms

When attempting to configure Microsoft Dynamics CRM for Microsoft Office Outlook, you receive the following error:

"There is a problem communicating with the Microsoft Dynamics CRM server. The server might be unavailable. Try again later. If the problem persists, contact your system administrator.

Error.AspNetInstallPath.Exception    at Microsoft.Crm.Application.Outlook.Config.ConfigInfo.GetAspDotNetPath()
   at Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.SetLaptopClientRegistryValues()
   at Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.SetConfigurationRegistryValuesAction()
   at Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.Configure(IProgressEventHandler progressEventHandler)
   at Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)"

↑ Back to the top


Cause

This error can occur if there is a problem with your installation of the Microsoft .NET Framework. 

↑ Back to the top


Resolution

Option 1

Download and run the Microsoft .NET Framework Repair Tool.



Option 2 (Windows 8 or later)

Uninstall and reinstall the .NET Framework.

NOTE: CRM 2013 for Outlook uses .NET Framework 4 or later. CRM 2015 for Outlook uses .NET Framework 4.5 or later. CRM 2016 for Outlook uses .NET Framework 4.5.2 or later.

1. Access the Control Panel and then open Uninstall a Program (Programs and Features).

2. Click Turn Windows features on or off.

3. Remove the selection of the .NET Framework and then click OK.

4. Click Close.

5. Click Turn Windows features on or off

6. Enable the .NET Framework and also the ASP.NET option below it.

7. Click OK.



Option 3 (Windows 7)

Repair the .NET Framework within Add/Remove Programs

1. Access the Control Panel and then open Uninstall a Program (Programs and Features).

2. Select the Microsoft .NET Framework and then click Uninstall/Change.

3. Select the Repair option and then click Next.

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 3183901
Revision : 1
Created on : 1/7/2017
Published on : 8/3/2016
Exists online : False
Views : 228