Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FRx login errors after you install Dynamics GP 2015


View products that this article applies to.

Symptoms

You receive one of the following errors when you attempt to log into FRx after installing GP 2015 on the computer:


FRx32.OFSIMain.CheckOFSIConnection 8900: 445FRxMBSUtilObject doesn't support this action

or

FRx32.OFSIMain.CheckOFSIConnection 8900: -2147319779FRxMBSUtilAutomation error Library not registered.

↑ Back to the top


Cause

This issue occurs because Dexterity 14.0 that comes with GP 2015 breaks the FRx login. FRx is not supported with GP 2013 or GP 2015 but you may have a business need to keep it around to connect to GP2 010 or GP10 for legacy report or upgrade purposes. 

Note FRx is only supported with GP 2010 and GP 10. If you need a reporting tool to connect to GP2013 or GP2015, the supported option is to upgrade to Management Reporter 2012:

https://mbs.microsoft.com/customersource/northamerica/MR/downloads/service-packs/MROverview

↑ Back to the top


Resolution

There are a couple of options for keeping FRx around to connect to GP 2010 or GP 10:

Option 1 

Install and run FRx from a 32-bit machine that has not had a GP 2015 client installed on it.


Option 2

If FRx is needed on a computer where GP 2015 has been installed, both GP 2015 and Dexterity14 will need to be removed. In some cases, all instances of GP and Dexterity need to be removed and then you can reinstall GP 2010/Dexterity11 or GP 10/Dexterity10. This should give you a GPConn.dll file of 11.X or 10.X in one or both of these folders:

C:\Program Files (x86)\Common Files\Microsoft Shared\Dexterity

C:\Program Files\Common Files\Microsoft Shared\Dexterity



You may need to manually register the correct 11.X or 10.X version of GPConn.dll with these steps:

1. Use Windows Explorer to find the file, right-click on it, choose Open With, and Choose Program. 
2. In the Open With dialog box, click Browse, then browse to the Windows\System32 folder on drive C. 
 In the System32 folder, highlight the Regsvr32.exe file and click Open.   In the System32 folder, highlight the Regsvr32.exe file and click Open.  
4. Click OK and you should receive a message that the file registered successfully.

↑ Back to the top


Keywords: kbmbsmigrate, kbmbspartner, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 3161310
Revision : 1
Created on : 1/7/2017
Published on : 5/9/2016
Exists online : False
Views : 272