Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Microsoft Dynamics CRM 2016: Export/Import of Interactive Dashboards


View products that this article applies to.

Symptoms

In CRM 2016, there are known issues with solution export and import of Interactive Dashboards that are based on custom Entity or custom Activity, or contain custom Views. CRM uses ObjectTypeCode (OTC) to match subcomponents in a solution entity to the correct entity on the target CRM system. This works as expected for out of the box (OOTB) entities and views, but it can create inconsistencies when the solution contains Interactive Dashboards based on custom Entity or Activity, and custom Views. The following example illustrates the possible inconsistencies.

↑ Back to the top


Cause

When a custom entity A is imported into a target system, such that an existing entity B in the target system has the same ObjectTypeCode as entity A, entity A is created on the system with a new ObjectTypeCode. This can create two kinds of inconsistencies:
  • The entity dashboards of entity A in the solution appear under the Entity Dashboard node of entity B, as the EntityTypeCode reference is resolved incorrectly.
  • All the streams and tiles with a reference to the entity A are incorrectly resolved as references to entity B. Thus, customized IC dashboards interpret such streams and tiles as composed of entity B, although their View is of entity A. The dashboard filter entity is also interpreted incorrectly as entity B. This leads to an inconsistent state where the dashboard cannot display the streams or tiles.
Secondly, there is no dependency calculation for streams, tiles, filter entity and filter view. While exporting an Interactive dashboard, the system does not prompt the user to export entity A, even if the dashboard contains streams or tiles based on the entity A. This could either lead to the scenarios mentioned above, or make it impossible for the target system to resolve the dependencies.

↑ Back to the top


Resolution

Solution export and import of Interactive dashboards is not a supported feature in CRM 2016. A patch will be available in CRM 2016 Update 2 to block the functionality from customization UI and SDK. When a solution is exported, the XML would not contain those subcomponent types which could create the inconsistencies discussed above. Interactive dashboards will not be made a part of the XML.

↑ Back to the top


More Information

The following screenshots show where this is going to be blocked:
  1. New Interactive dashboard in Custom Solution.11
  2. Existing Interactive dashboard in Custom Solution.22
  3. When solution components are added from the following menu, Interactive dashboards would not be shown in the list of available dashboards.33
  4. Entity Dashboard node during addition of assets to solution – the tab would be removed.44
  5. Entity Dashboard node under an added entity – the node would be removed.55

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 3160775
Revision : 1
Created on : 1/7/2017
Published on : 5/5/2016
Exists online : False
Views : 212