Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An IrDA networking device does not work in Windows 10 version 1511


View products that this article applies to.

Symptoms

In Windows 10 version 1511, IrDA devices do not communicate. This issue occurs even though IrDA network devices are displayed in Device Manager and the IrDA driver appears to be installed. There is no indication that the device is not working other than the lack of IrDA communication.

↑ Back to the top


Cause

This issue occurs because Windows 10 has an updated network binding engine (NetSetup) that doesn’t correctly handle IrDA network binding. Even though the device is recognized, a driver installed, and the device is started, the system cannot communicate by using the IrDA device because the network protocol is not bound to the driver.

↑ Back to the top


Resolution

This issue is fixed in Cumulative update for Windows 10 Version 1511 and Windows Server 2016 Technical Preview 4, which was released on April 12, 2016.

Note For Windows 10 systems, this cumulative update applies only to Windows 10 Version 1511.

After you install the cumulative update, you must run several commands and then restart the computer to bind the IrDA protocol and enable the IrDA services.

To enable IrDA networking after you install the cumulative update, follow these steps.

Note These commands apply only to Windows 10 Version 1511.

  1. Manually configure the IrDA network by unbinding and binding the IrDA protocol. To do this, follow these steps:

    1. Open an elevated Command Prompt window.
    2. At the command prompt, type the following commands, and press Enter after each command:

      netcfg –u ms_irda netcfg –c p –I ms_irda 
  2. Flush the updated configuration information to the registry. To do this, follow these steps:

    1. In Control Panel, open the Device Manager item.
    2. Expand the Network adapters node to show all network devices.
    3. Right-click the IrDA network device, and then select Properties.
    4. In the Properties window for the IrDA device, click the Advanced tab.
    5. Click OK.
    6. Close Device Manager
  3. Restart the computer.
  4. Verify that IrDA is restored by checking whether the irda and irmon IrDA services are running. To do this, follow these steps:

    1. Open an elevated Command Prompt window.
    2. At the command prompt, type the following command, and then press Enter:

      sc query irda 

      The STATE value of the irda service should be RUNNING, as shown in the following example:

      C:\>sc query irda

      SERVICE_NAME: irda
      TYPE : 1 KERNEL_DRIVER
      STATE : 4 RUNNING
      (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
      WIN32_EXIT_CODE : 0 (0x0)
      SERVICE_EXIT_CODE : 0 (0x0)
      CHECKPOINT : 0x0
      WAIT_HINT : 0x0
    3. Type the following command, and then press Enter:

      sc query irmon 
      The STATE value of the irmon service should be RUNNING, as shown in the following example:

      C:\>sc query irmon

      SERVICE_NAME: irmon
      TYPE : 20 WIN32_SHARE_PROCESS
      STATE : 4 RUNNING
      (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
      WIN32_EXIT_CODE : 0 (0x0)
      SERVICE_EXIT_CODE : 0 (0x0)
      CHECKPOINT : 0x0
      WAIT_HINT : 0x0

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 3150989
Revision : 1
Created on : 1/7/2017
Published on : 6/29/2016
Exists online : False
Views : 198