Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Try to download again" error when you try to install Microsoft Store for Business applications


View products that this article applies to.

Symptoms

Applications that are available through the Microsoft Store for Business private store appear as expected. However, Windows 10 users can't install these applications. Instead, they are prompted with the following: 
 
Try to download again 
Something happened on our end

↑ Back to the top


Cause

This is the expected behavior in Windows 10 build 10240. The private store functionality of the Microsoft Store for Business requires Windows 10 with the November 2015 update.  

↑ Back to the top


Resolution

Update the Window 10 device to version 1511. To verify what version and build of Windows 10 the device is running, run winver at a command prompt. 

↑ Back to the top


Keywords: kbexpertiseadvanced, kbsurveynew, kbtshoot, kb

↑ Back to the top

Article Info
Article ID : 3143796
Revision : 3
Created on : 10/16/2017
Published on : 10/26/2017
Exists online : False
Views : 289