Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"You do not have permission to access these records" error when you click Track in CRM


View products that this article applies to.

Symptoms

When you click Track in CRM within Microsoft Dynamics CRM for Outlook, it fails with the following error:

"You do not have permission to access these records. Contact your Microsoft Dynamics CRM administrator."

↑ Back to the top


Cause

Your user record in Microsoft Dynamics CRM is missing read access for the Record Creation and Update Rule entity. Microsoft is aware of this issue and plans to provide a fix so this privilege is not required to track emails. In the meantime, you can use the workaround provided in the Resolution section.

↑ Back to the top


Resolution

Sign into Microsoft Dynamics CRM as a user with the System Administrator role. Locate the security role assigned to the user. On the Service Management tab of the security role, grant Read access for the Record Creation and Update Rule entity.

↑ Back to the top


More Information

If you capture client side CRM tracing, the following information is logged:

Principal user (Id={GUID}, type=8) is missing prvReadConvertRule privilege (Id=a51aa4b3-b0c3-4b81-a290-9ed4b0db8fb1)
2015-08-21T15:27:32.0596285Z

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 3140750
Revision : 1
Created on : 1/7/2017
Published on : 2/4/2016
Exists online : False
Views : 260