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Failing to set a proxy server in Microsoft Azure Recovery Service Agent


View products that this article applies to.

Symptoms

When you try to set a proxy by using the Register Server command in the Microsoft Azure Backup snap-in, the server is not registered, and you receive the following error message:

Failed to re-enable existing scheduled backup settings. The server must be registered with Microsoft Azure Backup before this operation can be performed.

Or, you receive the following error message when you set a proxy by using the Change Properties command in the Microsoft Azure Backup snap-in:

Microsoft Azure Recovery Services Agent could not connect to the proxy server.(ID: 280011)
Please check the server settings and verify that the proxy server address is correct.

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Cause

This problem occurs if the proxy setting is missing in the CBSettings.xml file.

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Workaround

To work around this problem, add the proxy setting to CBSettings.xml, and then restart Microsoft Azure Recovery Service Agent.

CBSettings.xml is stored in the scratch folder that you specified as "Cache Location" during the installation of Microsoft Azure Recovery Service Agent. By default, the scratch folder is located in the following path:

C:\Program Files\Microsoft Azure Recovery Services Agent\Scratch
The current scratch folder path is stored in the following registry subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Azure Backup\Config\ScratchLocation

To set a proxy, follow these steps:

  1. Copy the CBSettings.xml file to any folder as a backup.
  2. Close the Microsoft Azure Backup snap-in if it's running.
  3. Open CBSettings.xml.
  4. Update the <ProxySetting> line, and then save the file. If <ProxySetting> is missing in the CBSettings.xml, add it. If <ProxySetting> already exists, replace it. For example, enter the following line in CBSettings.xml Contents:

    <ProxySetting><Enabled>true</Enabled><ProxyServer>http://10.10.10.10</ProxyServer><ProxyPort>80</ProxyPort></ProxySetting>
  5. Open the Services Management console (Services.msc).
  6. Right-click the "Microsoft Azure Recovery Services Agent" service, and then click Restart.
  7. Start the Microsoft Azure Backup snap-in, and then verify that the proxy setting is set correctly by using the Change Properties command.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbexpertiseadvanced, kbsurveynew, kbtshoot, kb

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Article Info
Article ID : 3132419
Revision : 1
Created on : 1/7/2017
Published on : 2/9/2016
Exists online : False
Views : 1336