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XADM: Exchange 2000 Services Do Not Start and a "0x80040a01" Error Message Is Logged


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This article was previously published under Q312859

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Symptoms

The Exchange 2000 services do not start and the following event ID message is logged in the server application log:
Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 1005
Description: Unexpected error An unknown error has occurred. ID no: 80040a01 Microsoft Exchange System Attendant occurred.

For more information, click http://search.support.microsoft.com/search/?adv=1.
The event ID 1005 message may also be generated by other Exchange 2000 services, such as Instant Messaging.

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Cause

This issue may occur if a domain controller or a global catalog is not available or if there is only a very slow connection to the domain controller or global catalog. When Exchange 2000 services start, they must contact a domain controller to read configuration information from Active Directory. The default timeout for topology creation is set to 1 minute after you apply Service Pack 2 (SP2) for Exchange 2000. If Exchange 2000 services cannot contact the domain controller or the global catalog during this time period, the system attendant (Mad.exe) generates a 0x80040a01 error, which is the error code that occurs if DSAccess topology creation times out.

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Workaround

To prevent this issue from occurring, make sure that the Exchange 2000 computers have high-bandwidth access to Windows 2000-based domain controllers or global catalog servers, and then verify that existing domain controllers or global catalog servers are running and functional.

Alternatively, if you install Exchange 2000 SP2 or later, modify the default topology detection timeout registry value setting. This registry value is not present by default. If this registry value is not present, Exchange 2000 uses a value setting of 0x3C (60 decimal) seconds.

To modify the default topology detection registry value:
  1. Start Registry Editor (Regedt32.exe).
  2. Locate and click the following key in the registry:
    HKEY_LOCAL_Machine\System\CurrentControlSet\Services\MSExchangeDSAccess
  3. On the Edit menu, click Add Value, and then add the following registry value:
    Value name: TopoCreateTimeoutSecs
    Data type: REG_DWORD
    Radix: Decimal
    Value data: 600
  4. Quit Registry Editor.
A value setting of 600 seconds is a good starting setting, but you can reduce this setting if you want. This new registry value setting does not indicate that Exchange 2000 services (which depend on DSAccess) take 10 minutes to start; instead, this value indicates that DSAccess has 10 minutes to discover the topology.

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More information

To increase the DSAccess logging level on the Exchange 2000 computer:
  1. Click Start, point to Programs, click Microsoft Exchange, and then click System Manager.
  2. Browse to the following location, where Server is the server that you want to troubleshoot and Administrative Group is the administrative group in which this server is located:
    Organization\Administrative Groups\Administrative Group\Servers\Server
  3. Right-click Server and click Properties.
  4. Click the Diagnostics Logging tab, click the MSExchangeDSAccess service, and then set the Topology category to Medium or higher.
If you increase the logging levels, some or all of the following event ID messages may be logged in the application log. Use these messages to help you troubleshoot this issue:
Event Type: Error
Event Source: MSExchangeDSAccess
Event Category: Topology
Event ID: 2107
Date: 6/12/2001
Time: 6:13:56 PM
User: N/A
Computer: ComputerName
Description: DSAccess failed to obtain an IP address for DS server %3, error %4. This host will not be used as a DS server by DSAccess.
-and-
Event Type: Error
Event Source: MSExchangeDSAccess
Event Category: Topology
Event ID: 2107
Date: 6/12/2001
Time: 6:13:56 PM
User: N/A
Computer: ComputerName
Description: DSAccess failed to obtain DNS records for domain %3. DNS Priority and Weight for the Domain Controllers in this domain will be set to the default values %4 (priority) and %5 (weight).
-and-
Event Type: Error
Event Source: MSExchangeDSAccess
Event Category: Topology
Event ID: 2104
Date: 2/14/2002
Time: 5:18:24 PM
User: N/A
Computer: ComputerName
Description: Process MAD.EXE (PID=1660). All the DS Servers in domain are not responding.

For more information, click http://search.support.microsoft.com/search/?adv=1.
-and-
Event Type: Error
Event Source: MSExchangeMU
Event Category: General
Event ID: 1002
Date: 2/14/2002
Time: 5:18:33 PM
User: N/A
Computer: ComputerName
Description: Metabase Update agent failed to start. Error code is 80040a01.

For more information, click http://search.support.microsoft.com/search/?adv=1.
-and-
Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 9004
Date: 2/14/2002
Time: 5:18:33 PM
User: N/A
Computer: ComputerName
Description: The Metabase Update service failed to start, error '80040a01'. For more information, click http://search.support.microsoft.com/search/?adv=1.
For additional information about how to troubleshoot the event ID message that is described in the 'Symptoms' section of this article, click the article number below to view the article in the Microsoft Knowledge Base:
318431� XADM: System Attendant Fails to Start with 0x80040a01

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Keywords: KB312859, kbprb

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Article Info
Article ID : 312859
Revision : 6
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 409