Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

USB functionality stops working after a Bluetooth driver update on Windows 8.1 and Windows 7


View products that this article applies to.

Symptoms

After you update the Canon USB driver for Bluetooth devices through Windows Update or you connect any USB Bluetooth device that requires a driver update, USB functionality fails on Windows 8.1-based and Windows 7-based computers.

Additionally, when this issue occurs, Wi-Fi is disabled on Surface Pro and Surface Pro 2 devices.

This issue occurs if the generic USB driver for Bluetooth devices was updated between November 20, 2015, and November 25, 2015.

↑ Back to the top


Cause

This problem occurs because the Canon Generic USB driver for Bluetooth replaced the generic Windows USB Bluetooth driver for Bluetooth during the driver update. The Canon driver is not compatible with all devices.

↑ Back to the top


Resolution

To resolve this problem, manually recover the generic Windows USB Bluetooth driver. To do this, follow these steps:

  1. Log on to Windows as an administrator.
  2. Connect a Bluetooth device.
  3. Start Device Manager.

    For Windows 8.1:

    Type Device Manager in the search box, and then tap or press Enter.

    For Windows 7:

    Click Start, type Device Manager in the Start search box, and then press Enter.
  4. In Device Manager, expand Universal Serial Bus Controllers.
  5. Right-click Canon Generic USB Driver for Bluetooth, and then click Uninstall.
  6. In the Confirm Device Uninstall dialog box, select the Delete the driver software for this device checkbox, and then press OK.
  7. Under Universal Serial Bus Controllers, verify that the Canon driver is uninstalled.
  8. Restart the computer.
  9. Verify that the blue, oval Bluetooth icon appears in the notification at the far right of the taskbar.

↑ Back to the top


More Information

This issue is reported to have occurred in the following scenarios from November 20, 2015, to November 25, 2015:

  • In Windows Update, the user manually updated the USB Bluetooth driver that's listed as the following:

    Canon i-tech, Inc. - Other hardware - Canon Generic USB Driver for Bluetooth
  • Windows Update was set to update automatically on a computer that a USB Bluetooth driver installed.
  • On a computer that had never had a USB Bluetooth adaptor or other Bluetooth device connected, the user connected a Bluetooth device that required a newer driver than the generic Windows USB Bluetooth driver that was installed at that time.

↑ Back to the top


Status

Canon stopped the distribution of the Canon Generic USB driver for Bluetooth on November 25, 2015. Canon informed Microsoft about this issue and provided the steps that are provided in the "Resolution" section.

↑ Back to the top


Keywords: kbprb, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 3125437
Revision : 1
Created on : 1/7/2017
Published on : 12/12/2015
Exists online : False
Views : 158