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Poor wireless connectivity on Surface devices running Windows 10 and using Netgear R8000 or Verizon MiFi router


View products that this article applies to.

Symptoms

Consider the following scenario:

  • You're using a Surface 3, Surface Pro 3, Surface Pro 4, or Surface Book.
  • You have Windows 10 installed on the device.
  • You're using a Marvell Wi-Fi driver version 15.68.9030.41 or 15.68.9032.47.
  • You're connecting to a wireless network by using a Netgear R8000 router, a Verizon MiFi series router, or an ATT Unite Pro mobile Wi-Fi hotspot.
In this scenario, you experience poor or slow network performance and you can't connect to the Internet or to resources over the wireless network.

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Cause

Microsoft has identified a problem in the original version of the Marvell wireless adapter driver that shipped in Windows 10 and uses the WDI architecture. This problem can cause unstable connections in the scenario that's mentioned in the "Symptoms" section.

Note Multiple factors can influence wireless network connectivity and throughput, including but not limited to the following:

  • Environmental factors, such as heavy machinery or load-bearing structures
  • Wireless access point/router firmware revisions,
  • Wireless configuration settings in use
  • Software that is running in Windows
  • Proximity to other sources of electromagnetic (EM) signals
Microsoft recommends that customers who are troubleshooting wireless issues should try to isolate as many variables as possible in order to reach a successful resolution.

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Workaround

Until an updated Marvell driver is released to resolve this problem, use the following method to work around this problem:
  1. Click Start, type regedit, and then click or tap reg.exe to start the Registry Editor.
  2. Navigate to the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mrvlpcie8897
  3. Locate the item that is labeled “TxAMSDU.” Double-click this item, and then change the value from 1 to 0.
  4. Close Registry Editor.
  5. Click Start, click Power, and click Restart to restart Windows.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Article Info
Article ID : 3120242
Revision : 3
Created on : 7/19/2019
Published on : 7/20/2019
Exists online : False
Views : 319