Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Mailbox Manager may miss its schedule if the server is under load


View products that this article applies to.

This article was previously published under Q311497

↑ Back to the top


Symptoms

If you set the Mailbox Manager schedule to one 15-minute block, it is possible that the process will not run if the server is under load.

↑ Back to the top


Cause

The Mailbox Manager process is designed to wake and check the schedule every 15 minutes. The process (clean mailbox) may wake an instant before the scheduled block of time. If this occurs, it would see that it is not yet time to process mailboxes, and go back to sleep. If the wake-up time is delayed by the operating system so that the next schedule check is an instant after the 15 minute block, mailboxes would not be cleaned.

↑ Back to the top


Workaround

To work around this behavior, set two 15-minute time blocks (back-to-back) in the schedule. This greatly increases the chances that the Mailbox Manager process will run. However, if the server is not under load, or does not have very much to do on that cycle, it may run two cleanup processes rather than one.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB311497, kbnofix, kbbug

↑ Back to the top

Article Info
Article ID : 311497
Revision : 7
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 301