Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Event ID: 4101 Occurs in Application Log When You Install Commerce Server 2000 SP1


View products that this article applies to.

This article was previously published under Q311004

↑ Back to the top


Symptoms

The following error may be logged in the Application log after you install Commerce Server 2000 Service Pack 1 (SP1):
Event Type:	Error
Event Source:	Commerce Server 2000
Event Category:	None
Event ID:	         4101
Date:		10/18/2001
Time:		6:28:31 PM
User:		N/A
Computer:	         CommerceServer
Description:
Commerce Server: Skipping Commerce Server 2000 SP1 Upgrade. The file 
P1Setup.INI does not exist or does not contain the proper sections. Please 
refer to the Commerce Server 2000 SP1 Readme for additional information.
					

This error may be generated in the Application log even though Commerce Server 2000 SP1 Setup indicates that it has completed successfully.

This error has been known to occur if you are following the steps outlined in the Knowledge Base article Q297472, "Catalog Migration Switches for Upgrading Multiple Identical Catalog Servers" to avoid upgrading catalogs on all Web servers, and if you specify the following option in the [Catalog Migration] section of the SP1Setup.ini file:
[Catalog Migration]
RunCatalogMigration=NO
					
For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
297472� Catalog Migration Switches for Upgrading Multiple Identical Catalog Servers

↑ Back to the top


Cause

This Application log entry is caused by inaccurate error handling in the Commerce Server 2000 SP1 Setup program.

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Commerce Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
297216� INFO: How to Obtain the Latest Commerce Server 2000 Service Pack
Check the versions of the following Commerce Server DLLs to see if they have been upgraded:
  • Catalog.dll
  • CSDWDTSCatalogImp.dll
If the version of these DLLs is 4.0.2035.0, Commerce Server 2000 has been upgraded properly and the error message can be ignored.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Commerce Server 2000. This problem was first corrected in Commerce Server 2000 Service Pack 2 (SP2).

↑ Back to the top


Keywords: KB311004, kbfix, kbcommserv2000sp2fix, kbbug

↑ Back to the top

Article Info
Article ID : 311004
Revision : 2
Created on : 10/18/2002
Published on : 10/18/2002
Exists online : False
Views : 370