Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: SNA Print service print sessions do not send jobs after the SNA Server configuration is restored by using snacfg.exe


View products that this article applies to.

Symptoms

When the configuration of an SNA server is restored by using the snacfg.exe command prompt tool, SNA Print service print sessions do not send jobs to the printer.

↑ Back to the top


Cause

This issue occurs if the following conditions are true:

  • The print sessions were previously configured to print to file.
  • The option to print to file is cleared.
  • The path of the file was not deleted.

↑ Back to the top


Resolution

The fix that resolves this problem is included in the following cumulative updates for Host Integration Server:

Cumulative Update 2 for Host Integration Server 2016

Cumulative Update 4 for Host Integration Server 2013

Note This update adds a parameter to the snacfg.exe command prompt tool, /PRINTTOFILEENABLED:{ Yes | No }. If this parameter is absent or set to No, the print session is not enabled to print to file, regardless of whether the path of the file is present.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

Learn about the terminology Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kbQFE, kbfix, kbBug, kbExpertiseInter, kbsurveynew

↑ Back to the top

Article Info
Article ID : 3108391
Revision : 9
Created on : 10/27/2017
Published on : 11/24/2017
Exists online : False
Views : 282