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FIX: BizTalk Adapter for MQSC fails when using UTF-8 encoding after an update is applied


View products that this article applies to.

Summary

Consider the following scenario:
 
  • You update Microsoft Host Integration Server.
  • You set the Microsoft BizTalk Adapter for WebSphere MQ (MQSC Adapter) to use UTF-8 encoding.
  • You run the MQSC Adapter server. 
In this scenario, the MQSC Adapter server throws the following warning:
 
Biztalk Server, Event ID 5740

The Adapter "MQSC" raised an error message.
Details "Failure encountered while attempting to get message from queue. queue = <Queuename>, queueManager = <QueueManagerName>, reason code = 2394".
 

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Cause

The MQSC Adapter no longer handles UTF-8 encoding after you update Host Integration Server.
 

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Resolution

After you apply the fix that's mentioned in this section, the MQSC Adapter handles UTF-8 encoding correctly.

 

Cumulative update information

The fix that resolves this problem is included in the following cumulative updates for Host Integration Server:

Cumulative Update 2 for Host Integration Server 2016

Cumulative Update 4 for Host Integration Server 2013

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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem that is described in this article. This hotfix might receive additional testing. Therefore, if you're not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix. 

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to get the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that don't qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: 
 

Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you don't see your language, this is because a hotfix isn't available for that language.
 

Prerequisites

You must have cumulative update package 3 for Microsoft Host Integration Server 2013 installed to apply this hotfix.

For more information about how to get the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
3019572 Cumulative update package 3 for Host Integration Server 2013
 

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbqfe, kbsurveynew, kb, kbautohotfix, kbhotfixserver, kbfix, kbexpertiseinter

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Article Info
Article ID : 3108144
Revision : 37
Created on : 1/9/2018
Published on : 1/9/2018
Exists online : False
Views : 323