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"Invalid Argument" error when you attempt to configure Microsoft Dynamics CRM for Microsoft Office Outlook


View products that this article applies to.

Symptoms

When you try to configure Microsoft Dynamics CRM for Microsoft Office Outlook, you receive the following error message:

"Invalid Argument"

If you click Details or View the Log File, additional details like the following appear:

context    at Microsoft.Crm.Metadata.MetadataCache.GetInstance(IOrganizationContext context)
   at Microsoft.Crm.Application.ControlDescriptor.get_Metadata()
   at Microsoft.Crm.Application.FormDescriptor.GetChildColumns()
   at Microsoft.Crm.Application.FormDescriptor.AddHiddenControls(EntityMetadata entityMetadata)
   ...

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Cause

A fix is available for an issue that can cause this error to occur when Update 1 is installed on Microsoft Dynamics CRM 2015 for Microsoft Office Outlook. The issue can occur if you have a Lookup field on one of the following entities and that Lookup field is filtered based on another Lookup field that is not on the form.
  • Contact
  • Account
  • Lead
  • Incident (Case)
  • Contract
  • Opportunity

Example Scenario: The Contact field on the Incident (Case) form has the properties configured to use "Related Record Filtering" and "Only show record where" with the field set to "Responsible Contact (Cases). If the Responsible Contact field is not on the Incident (Case) form, this error can occur.

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 3093119
Revision : 1
Created on : 1/7/2017
Published on : 7/22/2016
Exists online : False
Views : 310