Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Errors when you sign up for or sign in to apps that are set up for Azure B2C


View products that this article applies to.

Symptoms

When you try to sign up for or sign in to an app that's set up for Microsoft Azure B2C, you may receive an error message that concerns an invalid URI or URL. The error differs for each identity provider that you may be using.

Here are some examples of these errors:
  • One or more of the URLs are not allowed by the app's settings. It must match the website URL or canvas URL, or the domain must be a subdomain of one of the app's domains.
  • The redirect URI that you provided has not been white-listed for your application.
  • The redirect URI in the request <example> does not match a registered redirect URI.

↑ Back to the top


Cause

This issue occurs if return URIs or URLs are entered incorrectly or if they contain uppercase letters.

↑ Back to the top


Resolution

To fix this, verify the following conditions:
  • All return URIs and URLs are entered correctly, and you can navigate to them successfully.
  • All return URIs and URLs contain only lowercase letters.

↑ Back to the top


Keywords: azuread, vkbportal343, kbexpertiseadvanced, kbsurveynew, kbtshoot, kb

↑ Back to the top

Article Info
Article ID : 3092596
Revision : 1
Created on : 1/7/2017
Published on : 9/17/2015
Exists online : False
Views : 420