An exception occurs when you sign in to an app that's set up for Azure B2C

Original product version:   Microsoft Entra ID
Original KB number:   3092592

Symptoms

When you try to sign up for, or sign in to, an app that's set up for Microsoft Azure B2C, you receive the following error message:

Server Error in '/' Application"

Response status code does not indicate success: 404 (Not Found)

Description : An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details : System.Net.WebException: The remote server returned an error. 404 (Not Found)

Source Error :
Line 106: {
Line 107: ...
Line 108: OpenIdConnectConfiguration config = await mgr.GetConfigurationAsync();
Line 109: ...
Line 110: }

Cause

This problem occurs if the Policy Name setting for sign-in, password reset, or the user profile is missing or incorrect in the web.config file for your app.

Resolution

To resolve this issue, follow these steps:

  1. Open the web.config file for your app.

  2. In this file, verify the following:

    • The ida:SignInPolicyId app key exists, and you've replaced the value with the name of the Sign-in policy that you provided in the Azure B2C Admin Portal.
    • The ida:PasswordResetPolicyId app key exists, and you've replaced the value with the name of the Sign-in policy that you provided in the Azure B2C Admin Portal.
    • The ida:UserProfilePolicyId app key exists, and you've replaced the value with the name of the Sign-in policy that you provided in the Azure B2C Admin Portal.

    The web.config file should resemble the following:

    <appSettings>
    ...
    <add key="ida:SignInPolicyId" value="B2C_Signin_Policy">
    <add key="ida:PasswordResetPolicyId" value="B2C_PasswordReset_Policy">
    <add key="ida:UserProfilePolicyId" value="B2C_UserProfile_Policy">
    ...
    </appSettings>
    

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.