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"You do not have a license" error when you configure Microsoft Dynamics CRM for Microsoft Office Outlook


Symptoms

When you try to configure Microsoft Dynamics CRM for Microsoft Office Outlook, you receive the following error message:

"You do not have a license to use Microsoft Dynamics CRM Online. Contact your Office 365 administrator to assign a Microsoft Dynamics CRM license to you."

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Cause

Your user account has not been assigned a Microsoft Dynamics CRM Online license.

NOTE: If you have an existing Office 365 subscription and later added a CRM Online subscription, a CRM Online license is not assigned to your user record automatically. If your user account has the Global Administrator or Service Administrator role, you can still sign into the CRM web application to perform administrative actions but cannot create records such as Accounts, Contacts, Leads, etc... You must have a CRM Online license assigned to successfully connect Microsoft Dynamics CRM for Microsoft Office Outlook to your CRM Online instance. Within the CRM Online web application, you can navigate to Settings | Security | Users and change the view to Administrative Access Users. This view displays users who have administrative roles in the Office 365 portal but do not have a CRM Online license assigned.

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Resolution

Sign into http://portal.office.com as a user with administrative privileges and assign a Microsoft Dynamics CRM Online license to your user account. It may take a few minutes before the license information synchronizes from Office 365 to Microsoft Dynamics CRM Online.

For detailed steps on how to assign a license in Office 365, refer to the following article:

Assign or unassign licenses for Office 365 for business
https://support.office.com/article/Assign-or-unassign-licenses-for-Office-365-for-business-997596B5-4173-4627-B915-36ABAC6786DC

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More Information

When you click Details on the error dialog or if you view the log file, the following error is shown:

  10:58:34|  Error| Exception : The user has not been assigned any License    at Microsoft.Crm.Application.Outlook.Config.ServerInfo.RunServerDiagnostics()
   at Microsoft.Crm.Application.Outlook.Config.ServerInfo.LoadUserInfo(IClientAuthProvider`1 orgAuthProvider)
   at Microsoft.Crm.Application.Outlook.Config.ServerInfo.Initialize(Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary, IClientAuthProvider`1 authenticatedProvider)
   at Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadDataToServerInfo()
   at Microsoft.Crm.Application.Outlook.Config.ServerForm.<InitializeBackgroundWorkers>b__3(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 3091628
Revision : 1
Created on : 1/7/2017
Published on : 1/5/2016
Exists online : False
Views : 71