Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Could not load file or assembly System.Data.SqlServerCe" error when you configure Microsoft Dynamics CRM for Microsoft Office Outlook


View products that this article applies to.

Symptoms

When you try to configure Microsoft Dynamics CRM for Microsoft Office Outlook, you receive the following error message

"There is a problem communicating with the Microsoft Dynamics CRM server. The server might be unavailable. Try again later. If the problem persists, contact your system administrator."

When you click details, the following additional detail is shown:

  Could not load file or assembly 'System.Data.SqlServerCe, Version=4.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.    at Microsoft.Crm.Application.SMWrappers.CrmSqlCeDatabase.CreateDatabase(Boolean force)
   at Microsoft.Crm.Application.SMWrappers.CrmSqlCeDatabase.Initialize()
   at Microsoft.Crm.Application.SMWrappers.CrmSqlCeDatabase.get_ConnectionString()
   at Microsoft.Crm.Application.Outlook.ClientMetadataCache.ClientMetadataSync.GetDataWriteFactoryInstance()
   at Microsoft.Crm.Application.Outlook.ClientMetadataCache.ClientMetadataSync.CreateDataWriter[TReturn](Func`2 action)
   at Microsoft.Crm.Application.Outlook.ClientMetadataCache.ClientMetadataSync.get_IsValid()
   at Microsoft.Crm.Application.Outlook.ClientMetadataCache.ClientDynamicMetadataCache.<>c__DisplayClass1d.<.ctor>b__1a()
   at Microsoft.Crm.Application.Outlook.ClientMetadataCache.DeferredMetadataCacheManager.ExecuteWaitUntilReady(Guid organizationId, Action action)
   at Microsoft.Crm.Application.Outlook.ClientMetadataCache.ClientDynamicMetadataCache..ctor(IOrganizationContext context, Boolean reloadAsynchronously)
   at Microsoft.Crm.Application.Outlook.ClientMetadataCache.ClientDynamicMetadataCache.LoadCache(IOrganizationContext context, Boolean unusedHere)
   at Microsoft.Crm.Metadata.MetadataCache.GetInstance(IOrganizationContext context)
   at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime()
   at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler
   at Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)

↑ Back to the top


Cause

Microsoft SQL Server Compact 4.0 SP1 is not installed. 

↑ Back to the top


Resolution

Install Microsoft SQL Server Compact 4.0 SP1 from the following URL:

http://www.microsoft.com/download/details.aspx?id=30709

↑ Back to the top


More Information

If you are still encountering issues connecting CRM for Outlook to your CRM Online organization, a diagnostic tool is available to help diagnose the issue:

CRM for Outlook Configuration Diagnostic

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 3090728
Revision : 1
Created on : 1/7/2017
Published on : 2/4/2016
Exists online : False
Views : 298