Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FP2000: "Server Encountered an Error" Error Message When You Try to Connect to Microsoft Access Database


View products that this article applies to.

This article was previously published under Q308950

↑ Back to the top


Symptoms

When you use the Microsoft FrontPage 2000 Database Results Wizard to connect to a Microsoft Access database, the wizard may not retrieve the record source, and you may receive the following error message:
The server encountered an error while processing a
database request. For more information, click Details.
When you click Details, you receive additional information that is similar to the following:
Server error: Unable to connect to a database from the web server using
the connection string 'DRIVER={Microsoft Access Driver
(*.mdb)];DBQ=URL=fpdb/fpnwind.mdb'.

The following error message comes from the database driver software; it
may appear in a different language depending on how the driver is
configured.
-----------------------------------
Access is denied.
(ADODB.Connection)

Source:ADO
Number: -2147024891 (0x80070005)

↑ Back to the top


Cause

This behavior may occur if one or both of the following conditions are true:
  • The latest Microsoft Access drivers are not installed on your computer.
  • The user who is currently logged on cannot access the files needed to make the changes because of incorrect permissions settings on the necessary folders.

↑ Back to the top


Resolution

To resolve this issue, use the following methods, as necessary, in the order presented.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Method 1: Update the Microsoft Access Driver

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Data Sources (ODBC), and then click the Drivers tab.
  3. Verify that the version of the Microsoft Access Driver (*.mdb) is 4.00 or later.

    If your version is earlier than 4.00, visit the following Microsoft Web site to download the latest version:http://www.microsoft.com/downloads/-4e7d-b0b6-a8a94c4eb912&DisplayLang=en

Method 2: Change Permissions on the Files and Folders Necessary to Connect to the Database

Note The following steps apply only to the NTFS file system.
  1. Start Microsoft Windows Explorer.
  2. Find and then click the following folder:
    C:\Program Files\Common Files\System\ado
  3. On the File menu, click Properties.
  4. Verify that the Everyone group has Read and Execute (RX) permissions.
  5. Find the following folder, and then click Properties on the File menu:
    C:\WINNT
  6. Verify that the Everyone group has Read, Write, and Execute (RWX) permissions.
  7. Close the Folder Properties dialog box.

↑ Back to the top


References

For additional information, see the following articles in the Microsoft Knowledge Base:
237994� INFO: MDAC upgrade issues with Access ODBC driver

↑ Back to the top


Keywords: KB308950, kbprb, kberrmsg

↑ Back to the top

Article Info
Article ID : 308950
Revision : 4
Created on : 1/7/2006
Published on : 1/7/2006
Exists online : False
Views : 253