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Intermittent problems occur while peripherals are attached to a Surface Pro 3 device


View products that this article applies to.

Symptoms

When you work on a Surface Pro 3 device, you intermittently experience one of the following problems:

  • When you open the Type Cover, the Type Cover may not be detected correctly.
  • When you start the Surface device from a shutdown state or you restart the device while it is docked, the device may hang at the Surface logo or you receive a DRIVER_POWER_STATE_FAILURE error that indicates Stop error code 0x9F.

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Cause

These problems occur because of a timing issue in the system firmware that can sometimes prevent the Surface device from successfully enumerating attached peripherals. The timing issue may affect the Type Cover, USB devices, or external displays that are connected through the docking station.

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Resolution

To resolve these problems, install this update to install SAM firmware version 3.9.450.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites to install this hotfix.

Restart information

You must restart the Surface Pro 3 device when you install this hotfix.

Replacement information

This hotfix does not replace any previously released hotfix.

Installation instructions

  1. Make sure that your Surface Pro 3 is plugged into a power receptacle. When you install this update, do not run your Surface Pro 3 off battery power.
  2. Run the .exe file that you downloaded, and then double-click it to extract the file to a new folder on your Surface Pro 3.
  3. In Device Manager, expand the Firmware node, right-click Surface Pro System Aggregator Firmware, and then click Update Driver Software.
  4. Click Browse my computer for driver software, browse to the new folder that contains the contents that were extracted from the hotfix package, leave the Include subfolders option selected, and then click Next.
  5. After you receive the following message, click Close:

    Windows has successfully updated your driver software.
  6. When you are prompted to restart your computer, click Yes.

    Note When your Surface Pro 3 restarts, the "Surface" logo may remain on the screen for some time, and the screen may flash off and on several times. Eventually, you see a progress bar and the following text: "Please wait while we apply a system update. When the installation is completed, Windows restarts.
  7. In Device Manager, verify that the Surface Pro System Aggregator Firmware version is now 3.9.450.0.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File nameFile versionFile sizeDateTimePlatform
Driverlanguagemap.xmlNot applicable2,01029-Jul-201519:21Not applicable
Samfirmware.3.9.450.0.capNot applicable753,66429-Jul-201516:59Not applicable


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kb

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Article Info
Article ID : 3087655
Revision : 1
Created on : 1/7/2017
Published on : 8/20/2015
Exists online : False
Views : 272