Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

No programs or apps after upgrading to Windows 10


View products that this article applies to.

Symptoms

After upgrading to Windows 10, none of the apps you had prior to upgrading are available or listed in Start.

↑ Back to the top


Cause

This can happen if, prior to upgrading:

  • The "Program Files" directory is not located on the system drive.
  • The "Program Files (x86)" directory is not located on the system drive.
  • The "ProgramData" directory was relocated from the default location on the "%systemdrive%" drive (the drive that contains the Windows directory). 

↑ Back to the top


Resolution

You will need to go back to your previous version, backup your data, and then reset or re-install Windows and your Apps, so that the “ProgramData” and “Program Files / x86" folders are located on the System drive.

Relocation of the "ProgramData," “Program Files” or "Program Files / x86" directory is not supported in Windows.   In order to upgrade to Windows 10 these folder must be on the system drive.

Backup information:
Reset and Restore information:

↑ Back to the top


More Information

Redirecting ProgramData or Program Files causes different issues in Windows 8 or 8.1, and redirecting “Users” folders causes other issues in both Windows 10 and 8/8.1 . For more information about that, see Knowledge Base article 2876597.

For more information about the Microsoft policy on relocating the "Users" and "ProgramData" directories, see Knowledge Base article 949977.

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 3086105
Revision : 1
Created on : 1/7/2017
Published on : 8/4/2015
Exists online : False
Views : 233