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Problems with automated installation of Host Integration Server clients


View products that this article applies to.

This article was previously published under Q307819

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Symptoms

When using .INF files to perform automated installations of the Host Integration Server (HIS) 2000 client software, several registry settings may be set incorrectly. These problems occur only when performing automated installations of the HIS 2000 client software. If an HIS 2000 client is installed through the standard interactive installation method, these problems do not occur.

The following problems may be experienced when using an .INF file to install the HIS 2000 End-User Client:
  • AcceptBackupInfo key is created, but contains no actual value.
  • AcceptSponsorListUpdate key is created, but contains no actual value.
  • AutoTerminate key is created, but contains no actual value.
  • ShowIcon key is created, but contains no actual value.
  • TerminationTimeout key is created, but always contains a value of zero.
  • RandomSponsor key is created, but always contains a value of zero.
  • SnaDomain key is created and populated with the local computer name if left blank in the .INF file.
The following problems may be experienced when using an .INF file to install the HIS 2000 Administrator Client:
  • AcceptBackupInfo key is not created.
  • AcceptSponsorListUpdate key is not created.
  • RandomSponsor key is not created.
  • ShowIcon key is not created.
  • TerminationTimeout key is not created.
  • RunAsService key is created but is always set to zero.
  • AutoTerminate key is created, but contains no actual value.

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Cause

The Microsoft Installer files (.MSI) for the HIS 2000 End-User Client and Administrator Client installations do not properly handle all of the entries in the .INF file.

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Resolution

Host Integration Server 2000 End User Client

To resolve this problem, obtain the latest service pack for Host Integration Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to Obtain the Latest Host Integration Server 2000 Service Pack

Host Integration Server 2000 Administrator Client

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
   23-Apr-2004  21:43                 30,046,208  Hiadmin.msi
				


Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

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Status

Host Integration Server 2000 End User Client

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Host Integration Server 2000 Service Pack 1.

Host Integration Server 2000 Administrator Client

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The valid entries for the .INF files are documented in the HIS 2000 Online Books under the topic "Installation and Configuration\Automating Setup."

The updated HiAdmin.msi package for the Host Integration Server 2000 Administrator client also includes the update descibed in the following Microsoft Knowledge Base article:
816879� RunMin.exe does not succeed when removing Host Integration Server 2000 Administrator Client

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Keywords: kbhostintegserv2000sp1fix, kbhostintegserv2000presp1fix, kbfix, kbbug, kbqfe, kbhotfixserver, kbautohotfix, KB307819

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Article Info
Article ID : 307819
Revision : 7
Created on : 2/22/2007
Published on : 2/22/2007
Exists online : False
Views : 308