Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An error occurs when connecting to the CRM app on an iPad or iPhone: "We're Sorry. Your server is not available or does not support this application."


View products that this article applies to.

Symptoms

When trying to connect an iPhone or iPad to the Dynamics CRM app, you may encounter the error: " We're Sorry. Your server is not available or does not support this application."

↑ Back to the top


Cause

SSL certificates generated by some external Certificate Authorities may have problems with the entire certificate chain being trusted when configuring the CRM app on an iPhone or iPad.

↑ Back to the top


More Information

Accessing the Microsoft Dynamics CRM site through a web application will work correctly. However, on iOS devices, the SSL certificate configured for AD FS and CRM may be seen as untrusted. You will see similar certificate related errors when using iOS apps that render the web pages using UIWebViews and WKWebViews. 


The iOS device logs will show: Authentication: Authentication Interrupted.


This has been encountered when the SSL certificate is a wildcard certificate for the entire domain such as *.contoso.com. The root domain such as https://contoso.com works correctly. Subdomains such as https://crm.contoso.com do not work as expected. This may be due to compatibility with iOS devices and certificates that list wildcard Subject Alternative Names. It is recommended to test with certificates whose root level includes the CRM subdomain such as *.crm.domain.com.

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 3069747
Revision : 1
Created on : 1/7/2017
Published on : 6/2/2015
Exists online : False
Views : 246