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Rotated italic text flows in the wrong direction when it's printed on a PCL6 printer in Windows 8.1


View products that this article applies to.

Symptoms

When you print XPS documents to a PCL6 printer, and these documents contain fonts that don't include italic type, rotated italic text is inclined and flows in the wrong direction.

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Cause

This problem occurs because PCL6 and XPS handle character transformations in the opposite order.

Msxpspcl6.dll identifies cases in which rotation is not supported and therefore falls back to rasterization. However, it does not identify cases in which there is a rotation and the font is italic type.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update in Windows 8.1, you must first have update 2919355 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 file information and notes

Important Windows 8.1 and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows 8.1" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.3.960 0.17 xxxWindows 8.1RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8.1 and Windows Server 2012 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Msxpspcl6.dll0.3.9600.178974,640,25603-Jun-201513:49x86
Msxpsps.dll0.3.9600.178964,602,36802-Jun-201516:29x86
V3hostingfilter-pipelineconfig.xmlNot Applicable38516-Dec-201400:36Not Applicable
V3hostingfilter.dll0.3.9600.1789644,03202-Jun-201516:36x86
For all supported x64-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Msxpspcl6.dll0.3.9600.178975,254,14403-Jun-201513:55x64
Msxpsps.dll0.3.9600.178965,243,39202-Jun-201517:16x64
V3hostingfilter-pipelineconfig.xmlNot Applicable38516-Dec-201418:03Not Applicable
V3hostingfilter.dll0.3.9600.1789657,34402-Jun-201517:26x64

Additional file information for Windows 8.1

Additional files for all supported x86-based versions of Windows 8.1
File nameX86_ntprint4.inf_31bf3856ad364e35_6.3.9600.17897_none_dab80bcdc01dca12.manifest
File versionNot Applicable
File size4,816
Date (UTC)04-Jun-2015
Time (UTC)00:27
Additional files for all supported x64-based versions of Windows 8.1
File nameAmd64_ntprint4.inf_31bf3856ad364e35_6.3.9600.17897_none_36d6a751787b3b48.manifest
File versionNot Applicable
File size4,828
Date (UTC)04-Jun-2015
Time (UTC)00:31

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbqfe, kbsurveynew, kbautohotfix, kbhotfixserver, kbfix, kbexpertiseinter, kbbug

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Article Info
Article ID : 3067900
Revision : 1
Created on : 1/7/2017
Published on : 7/14/2015
Exists online : False
Views : 163