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A Removed Disk Can Have Its Corresponding Cluster Resource Started


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This article was previously published under Q306640

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Symptoms

After you remove and replace a physical disk of the same geometry from a cluster during run-time (hot swapping), the original physical disk resource may still come online even though the disk signature of the new drive is different. The same behavior occur ifs the disk signature is changed or damaged while the cluster is in service. Although the new disk resource and the new disk appear to be online, they do not function properly, and Cluster Administrator may not fail the resource.

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Cause

Once the Cluster service has located a disk by its signature, it then controls the disk by the physical disk number, and does not recheck the disk signature until the computer is rebooted or the disk device is removed and re-added. Once a reboot occurs under these conditions, the new disk appears as Failed in Cluster Administrator.

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Resolution

After you remove a disk from the cluster, reboot the cluster or remove the disk device from Device Manager, and then run the rescan command in the Disk Management console to re-detect the new drive.

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Status

This behavior is by design.

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Keywords: KB306640, kbprb

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Article Info
Article ID : 306640
Revision : 9
Created on : 2/28/2007
Published on : 2/28/2007
Exists online : False
Views : 317