Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Active Directory Connector Upgrade Does Not Succeed If Certain Files Are in Use


View products that this article applies to.

Symptoms

The Active Directory Connector (ADC) Service Pack 1 (SP1) has its own Setup program in the ADC\i386 folder of the service pack. The installation of Microsoft Exchange 2000 Server SP1 or later does not automatically update the ADC. When you run the ADC Setup program, the ADC is actually reinstalled from the original released version to the SP1 version. In some cases, not all the files are updated correctly, and you are prompted by the ADC Setup program to abort, retry, or ignore. If you select Retry, the Setup program does not succeed, and if you select Ignore, the files are not updated correctly.

The four files that are not updated are Exchmem.dll, Address.dll, Escprint.dll, and Maildsmx.dll.

↑ Back to the top


Cause

This behavior may occur if the Active Directory Users and Computers snap-in is running when you run the Setup program, because the Active Directory Users and Computers snap-in uses the files that are listed in the "Symptoms" section of this article.

↑ Back to the top


Resolution

To resolve this behavior, close all Exchange-related Microsoft Management Console (MMC) snap-ins before you run any type of Exchange setup or update program.

↑ Back to the top


Keywords: KB306505, kbprb

↑ Back to the top

Article Info
Article ID : 306505
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 303