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Cannot resolve a subdomain name because the negative cache is counting down on a DNS server that is running Windows Server 2012 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure an authoritative Domain Name System (DNS) that has a zone such as contoso.com on a server that is running Windows Server 2012 R2.
  • You configure the Time to Live (TTL) value for the Start of Authority (SOA) resource record at 1 (one) minute. You leave the minimum zone TTL that is defined in the SOA at its default setting of 1 (one) hour.
  • You configure a recursive server that uses a conditional forwarder for the contoso.com zone. The conditional forwarder points to the server that is configured in the first bullet point.
  • On the recursive server, you query the localhost for a subdomain record that does not exist in the zone, such as sales.contoso.com. Notice that you will receive a response that contains the SOA as configured at a TTL of 3600 (not 60, which is the correct value per the DNS RFC).
  • You query the same nonexistent subdomain record again and notice that the negative cache is counting down.
  • You create the "sales" subdomain record on the authoritative server. Then, you repeat bullet item 3 to query for this new record. 

In this scenario, you cannot resolve the subdomain name because the negative cache is still counting down.

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Cause

When the Domain Name System (DNS) replies by sending a name error or empty authority response, the TTL of the SOA record in the answer should be the minimum TTL for the SOA TTL and the SOA Minimum TTL.

However, a Windows Server 2012 R2-based recursive DNS server incorrectly always uses the SOA Minimum TTL when it calculates the TTL value. This hotfix forces the server to use the minimum value for the SOA TTL and the SOA Minimum TTL.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update in Windows Server 2012 R2, you must first have update 2919355 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2012 R2 file information and notes

Important Windows 8.1 and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows 8.1" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1" on the page. Always refer to the "Applies to" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.3.960 0.17xxxWindows Server 2012 R2RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8.1 and Windows Server 2012 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Cache.dnsNot Applicable3,19818-Jun-201314:43Not applicable
Dns.exe6.3.9600.178981,734,65604-Jun-201516:20x64
Dnsserver.events.xmlNot Applicable60918-Jun-201314:43Not applicable

Additional file information for Windows Server 2012 R2

Additional files for all supported x64-based versions of Windows Server 2012 R2
File nameAmd64_9995970d522adc8fc209f64c36d36fb6_31bf3856ad364e35_6.3.9600.17898_none_560a97e6cf1a2d30.manifest
File versionNot applicable
File size710
Date (UTC)06-Jun-2015
Time (UTC)20:05
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameAmd64_microsoft-windows-dns-server-service_31bf3856ad364e35_6.3.9600.17898_none_3ebd6972aa902c30.manifest
File versionNot applicable
File size287,181
Date (UTC)05-Jun-2015
Time (UTC)07:56
SHA-1 hashNot applicable
MD5 hashNot applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kbbug, kbexpertiseinter, kbfix, kbqfe, kbautohotfix, kbsurveynew, kb, kbhotfixserver

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Article Info
Article ID : 3064749
Revision : 1
Created on : 1/7/2017
Published on : 7/14/2015
Exists online : False
Views : 187