Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Visual Studio 2015 RC repeatedly prompts you to enter credentials



IMPORTANT NOTE: Users that installed the patch associated with this KB may experience issues when signing into Visual Studio after upgrading to the RTM version. To fix issues that are caused by this patch in RTM, first uninstall the patch by searching in the Start menu for "Program and Features", then click "View Installed Updates". Select the update for KB3061894 then click Uninstall. After the uninstall completes click "Uninstall a Program" to return to the list of installed program. Find Visual Studio and click Change. When the Visual Studio setup dialog appears click Repair to ensure Visual Studio re-applies the RTM files.

↑ Back to the top


Symptoms


Microsoft Visual Studio 2015 Release Candidate (RC) repeatedly prompts you to enter your user credentials when you sign in to the program or when you access different features in Visual Studio. This can occur immediately after you successfully enter the correct credentials for a Microsoft account or for a work or school account. This issue can also occur intermittently when you access different features in Visual Studio.

↑ Back to the top


Cause

This issue has two separate causes.
Cause 1
Version 2.11 of the Azure Active Directory Authentication Library (ADAL) is not setting the internal IsMultipleResourceRefreshToken flag correctly for tokens that are associated with a Microsoft account.

Cause 2
The Internet Explorer session count may decrement to zero (0) during the process to acquire tokens that are required to access resources in Visual Studio.

↑ Back to the top


Resolution

Download information


The download for the patch has been removed due to issues it was causing with users that upgrade to the RTM version of Visual Studio. We recommend users upgrade to the latest version of Visual Studio which has incorporated this fix.

Download the latest version of Visual Studio now.

↑ Back to the top


Workaround

To work around this issue, start an instance of Internet Explorer when you use Visual Studio. This may prevent this issue from occurring. However, this workaround will not resolve all repeated prompts.

↑ Back to the top


More Information

Prerequisites

To install this hotfix, you must have Visual Studio 2015 RC installed.

Restart Requirement

You must restart Visual Studio 2015 RC after you install the hotfix.

↑ Back to the top


Keywords: kbsurveynew, kbexpertiseadvanced, kbfix, atdownload, kb

↑ Back to the top

Article Info
Article ID : 3061894
Revision : 1
Created on : 1/7/2017
Published on : 7/23/2015
Exists online : False
Views : 72