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You cannot upgrade Hyper-V integration components or back up Windows virtual machines


View products that this article applies to.

This article describes an issue that occurs when you upgrade Microsoft Hyper-V integration components (integration services) of a Windows 8 or Windows Server 2012 virtual machine that has SR-IOV enabled, running on a Windows 8.1 or Windows Server 2012 R2 Hyper-V host. A hotfix or an update is available to resolve this issue. Before you install this hotfix or this update, check out the Prerequisites section.

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Symptoms

Integration services setup always prompts for upgrade, even though the components are upgraded successfully for a Windows 8 or Windows Server 2012 virtual machine that has SR-IOV enabled. The Best Practice Analyzer (BPA) reports the integration services version as old or out-of-date.

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Cause

This issue occurs because Hyper-V integration components services report the incorrect version during the integration components installation, even though all the components are upgraded successfully.

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Resolution

Important Do not install a language pack after you install this update. If you do, the language-specific changes in the update will not be applied, and you will have to reinstall the update. For more information, see Add language packs to Windows.

Method 1: Windows Update

This update is provided as an Optional update on Windows Update. For more information on how to run Windows Update, see How to get an update through Windows Update.

Method 2: Hotfix

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this hotfix, you must have update 2919355 installed in Windows 8.1 or Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 and Windows Server 2012 R2 file information and notes

Important Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1/Windows Server 2012 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.3.960 0.16 xxxWindows 8.1 and Windows Server 2012 R2RTMGDR
    6.3.960 0.17 xxxWindows 8.1 and Windows Server 2012 R2RTMGDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Windows5.x-hypervintegrationservices-x64.msiNot applicable1,646,59213-Mar-201505:46Not applicable
Windows5.x-hypervintegrationservices-x64.xmlNot applicable13013-Mar-201500:51Not applicable
Windows6.2-hypervintegrationservices-x64.cabNot applicable770,89913-Mar-201505:58Not applicable
Windows6.x-hypervintegrationservices-x64.cabNot applicable700,86013-Mar-201505:52Not applicable
Windows6.x-hypervintegrationservices-x64.xmlNot applicable16813-Mar-201500:51Not applicable
Setup.exe6.3.9600.17728141,96813-Mar-201505:39x64
Windows5.x-hypervintegrationservices-x86.msiNot applicable1,363,96813-Mar-201504:48Not applicable
Windows5.x-hypervintegrationservices-x86.xmlNot applicable13013-Mar-201500:50Not applicable
Windows6.2-hypervintegrationservices-x86.cabNot applicable615,35313-Mar-201505:02Not applicable
Windows6.x-hypervintegrationservices-x86.cabNot applicable617,47813-Mar-201504:56Not applicable
Windows6.x-hypervintegrationservices-x86.xmlNot applicable16813-Mar-201500:50Not applicable
Setup.exe6.3.9600.17728125,58413-Mar-201504:41x86

Additional file information

Additional file information for Windows 8.1 and for Windows Server 2012 R2


Additional files for all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File propertyValue
File nameAmd64_489bfc7fb9bf0976301253b730e87b0e_31bf3856ad364e35_6.3.9600.17728_none_cb162bbe334affcb.manifest
File versionNot applicable
File size1,082
Date (UTC)13-Mar-2015
Time (UTC)18:09
PlatformNot applicable
File nameAmd64_9392355a462dc42af47393ee4a8363ef_31bf3856ad364e35_6.3.9600.17728_none_fde1b5e026a9f2d7.manifest
File versionNot applicable
File size1,082
Date (UTC)13-Mar-2015
Time (UTC)18:09
PlatformNot applicable
File nameAmd64_b22200eb4d928b35a4e043d247b96780_31bf3856ad364e35_6.3.9600.17728_none_345ed46387475098.manifest
File versionNot applicable
File size1,054
Date (UTC)13-Mar-2015
Time (UTC)18:09
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-g..aller-win5x-package_31bf3856ad364e35_6.3.9600.17728_none_c3305b715e16f8d3.manifest
File versionNot applicable
File size3,141
Date (UTC)13-Mar-2015
Time (UTC)05:47
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-g..aller-win6x-package_31bf3856ad364e35_6.3.9600.17728_none_c566c5839c6e2c44.manifest
File versionNot applicable
File size4,237
Date (UTC)13-Mar-2015
Time (UTC)06:00
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-guest-installer_31bf3856ad364e35_6.3.9600.17728_none_62a832b9f585ca58.manifest
File versionNot applicable
File size4,141
Date (UTC)13-Mar-2015
Time (UTC)05:47
PlatformNot applicable
File nameX86_microsoft-hyper-v-g..aller-win5x-package_31bf3856ad364e35_6.3.9600.17728_none_6711bfeda5b9879d.manifest
File versionNot applicable
File size3,135
Date (UTC)13-Mar-2015
Time (UTC)04:50
PlatformNot applicable
File nameX86_microsoft-hyper-v-g..aller-win6x-package_31bf3856ad364e35_6.3.9600.17728_none_694829ffe410bb0e.manifest
File versionNot applicable
File size4,229
Date (UTC)13-Mar-2015
Time (UTC)05:03
PlatformNot applicable
File nameX86_microsoft-hyper-v-guest-installer_31bf3856ad364e35_6.3.9600.17728_none_068997363d285922.manifest
File versionNot applicable
File size3,198
Date (UTC)13-Mar-2015
Time (UTC)04:50
PlatformNot applicable


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

See the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, atdownload

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Article Info
Article ID : 3046826
Revision : 1
Created on : 1/7/2017
Published on : 6/23/2015
Exists online : False
Views : 216