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"Workplace Join discovery failed" error with exit code 0x80072F8A"


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Symptoms

When a user tries to perform a Workplace Join operation, she receives the following error message:

Confirm you are using the current sign-in info, and that your workplace uses this feature. Also, the connection to your workplace might not be working right now. Please wait and try again.

Additionally, an administrator may see the following event details in Event Viewer:

Event ID:102
Log Name:Microsoft-Windows-Workplace Join/Admin
Source:Microsoft-Windows-Workplace Join
Level:Error
Description:Workplace Join discovery failed.

Exit Code: 0x80072F8A.

The supplied certificate has been revoked. Could not connect to 'https://EnterpriseRegistration.domain.com:443/EnrollmentServer/contract?api-version=1.0'.

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Cause

This problem occurs because the DRS Service SSL certificate or a certificate in the issuance chain has been revoked.

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Resolution

To resolve this problem, try the following methods.

Method 1: Update the root certificates

To update the root certificates, run Microsoft Update, and then make sure that the updates for root certificates are all installed.

If this does not fix the problem, try the next method.

Method 2: Verify date and time settings, clear SSL state, and reregister DLL files

Try the methods that are listed in the following article in the Microsoft Knowledge Base:

813444 You cannot log in to or connect to secured Web sites in Internet Explorer

If this does not fix the problem, try the next method.

Method 3: Force CRL cache to expire

Open a Command Prompt window as an administrator, and then run the following command:

certutil -setreg chain\ChainCacheResyncFiletime @now

Note If there's a proxy server in the environment, make sure that the client is configured to use the proxy server.

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Workaround

To temporarily work around this problem, clear the Check for server certificate revocation check box under Advanced Settings Internet Options.

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References

For more troubleshooting information, see the following article in the Microsoft Knowledge Base:

3045377  Diagnostic logging for troubleshooting Workplace Join issues

For additional troubleshooting guidance that's specific to this problem, filter for Capi2 events 81, 11, and 30.

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Keywords: vkbportal343, kbexpertiseadvanced, kbsurveynew, kbtshoot, azuread, kb

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Article Info
Article ID : 3045383
Revision : 3
Created on : 9/6/2019
Published on : 9/6/2019
Exists online : False
Views : 643