Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Database opens for shared use even after you have set the default open mode option to exclusive


View products that this article applies to.

Symptoms

When you have set Default open mode to Exclusive on the Advance tab of the Options dialog box, and you then open a database by clicking Open Exclusive in the Open dialog box, Microsoft Access opens the database for shared use.

↑ Back to the top


Cause

If you set Default open mode to Exclusive, and you then click the arrow to the right of the Open button in the Open dialog box, you see that the Open Exclusive option has a check mark next to it. When you then click this item, the check mark is cleared. This causes the database to open in shared mode.

↑ Back to the top


Resolution

If you have the Default open mode set to Exclusive, click Open in the Open dialog box instead of Open Exclusive.

↑ Back to the top


Status

This behavior is by design. When you click the down arrow next to the Open button in the Open dialog box, the items in this list act as if they are toggle buttons. If an item already has a check mark next to it, when you click it again, the check mark is cleared. If an item does not have a check mark next to it and you click it, the item will be checked.

↑ Back to the top


More information

Steps to Reproduce the Behavior

  1. Start Access, and then open a database.
  2. On the Tools menu, click Options.
  3. In the Options dialog box, click the Advanced tab.
  4. Under Default open mode, click Exclusive, and then click OK.
  5. Quit and then restart Access.
  6. On the File menu, click Open.
  7. In the Open dialog box, select a database.
  8. Click the arrow next to the Open button, and then click Open Exclusive.
  9. On the Tools menu, point to Security, and then click Set Database Password.
  10. Note that you receive the following error message. This error message indicates that the database has been opened in shared mode.
    You need to have the database open for exclusive use to set or unset the database password.

    To open the database exclusively, close the database, and then reopen it using the Open command on the File menu. In the Open dialog box, click the arrow to the right of the Open button, and the choose Open Exclusive.

↑ Back to the top


Keywords: KB304528, kbprb, kbopenfile

↑ Back to the top

Article Info
Article ID : 304528
Revision : 9
Created on : 4/3/2007
Published on : 4/3/2007
Exists online : False
Views : 275