Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Internet Explorer Prompts for Credentials When Using a .pac File


View products that this article applies to.

Symptoms

If Internet Explorer is configured to use a .pac file to access different Web addresses (or URLs) that are hosted by the same host name through different means (for example, one through a proxy and another directly), Internet Explorer may return "Authentication failure" messages, prompt for credentials, and not allow access to certain Web sites.

↑ Back to the top


Cause

By default, Internet Explorer caches the connection (whether by a proxy or direct connection) that is used to access a specific host name. The EnableAutoproxyResultCache registry value was introduced to allow administrators to disable this proxy caching capability so that Internet Explorer can use different proxy servers to connect to different Web sites that are hosted on the same host name. Without this registry value, Internet Explorer always uses the proxy server through which the first connection to a specific host name is made, regardless of the settings in the .pac file. With this caching disabled, Internet Explorer reads the .pac file for each URL, but if Internet Explorer connects to a Web site on a specific host directly and then connects to a different Web site on the same host through a proxy server, it correctly tries to connect through the proxy server, but sends incorrect proxy authorization information.

↑ Back to the top


Resolution

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date          Time   Version         Size     File name     
   ---------------------------------------------------------
   27-July-2001  12:42  5.50.4719.2700  481,040  Wininet.dll

				

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


More information

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
271361 How to Disable Internet Explorer Automatic Proxy Caching

↑ Back to the top


Properties

↑ Back to the top


Keywords: kbnosurvey, kbhotfixserver, kbqfe, kbfix, kbie550presp2fix, kbprb, kbqfe, kbarchive, KB304112

↑ Back to the top

Article Info
Article ID : 304112
Revision : 6
Created on : 10/24/2013
Published on : 10/24/2013
Exists online : False
Views : 469