Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: Exchange 2000 Server User Mailbox Store Notification Does Not Work


View products that this article applies to.

This article was previously published under Q302929

↑ Back to the top


Symptoms

When a "fnevNewMail | fnevExtended" event mask is set in an Advise() call to the store, new mail notification may not work.

↑ Back to the top


Cause

This problem can occur because of an un-initialized variable in Exchange 2000 Server Service Pack 1 (SP1).

↑ Back to the top


Resolution

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Information store

File nameVersion
Store.exe6.0.4419.31
Excdo.dll6.0.4419.31
Exoledb.dll6.0.4419.31


For additional information a fix for this problem for Exchange 2000 Server SP1, click the article number below to view the article in the Microsoft Knowledge Base:
302925 Exchange 2000 SP1 User Mailbox Store Notification Failure

↑ Back to the top


Workaround

To work around this problem, use a "fnevNewMail" event mask instead of the "fnevNewMail | fnevExtended" event mask; if you do so, new mail notification works.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

↑ Back to the top


Keywords: KB302929, kbqfe, kbfix, kbexchange2000presp1fix, kbbug

↑ Back to the top

Article Info
Article ID : 302929
Revision : 6
Created on : 2/19/2007
Published on : 2/19/2007
Exists online : False
Views : 290