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FIX: Device Management API calls from a high-priority thread take a long time in Windows Embedded Compact 2013


View products that this article applies to.

Symptoms

Assume that a primary device that is running Windows Embedded Compact 2013 hosts a device driver, such as a COM port, a USB port, a multimedia device, or a Telnet virtual device. If a user application calls any Device Management API at the same time that some other process is closing a device driver, the API call takes much longer than expected to finish. 

For example, the user application sends a DeviceIoControl command to a CAN bus at the same time that telnetd is closing TEL0. In this situation, the API call in the user application may be blocked until telnetd is finished closing the device driver.

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Cause

This problem occurs because of a synchronization lock that is hosted in the device manager. Note that you cannot resolve this problem by assigning a higher priority to the user application. The kernel tracker log indicates that the low-priority thread was boosted by design to speed up the unlocking process. However, the low-priority thread was also blocked by some other thread.

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More Information

Software update information

An update is available to resolve this issue.

Download information

Windows Embedded Compact 2013 Monthly Update (December 2014) is now available from Microsoft. To download this Windows Embedded Compact 2013 monthly update, go to Microsoft OEM Onlineor MyOEM.

Prerequisites

To install this update, all previously issued updates for this product must be installed.

Restart requirement

After you apply this update, you must perform a clean build of the whole platform. To do this, use one of the following methods:
  • On the Build menu, click Clean Solution, and then click Build Solution.
  • On the Build menu, click Rebuild Solution.
You do not have to restart the computer after you apply this software update.

Update replacement information

This update does not replace any other updates.

File information
The English version of this software update package has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Files that are included in this hotfix package
File nameFile sizeDateTimePath
Devcore.lib889,45431-Dec-201406:26Public\Common\Oak\Lib\X86\Retail
Devcore.lib928,57831-Dec-201406:26Public\Common\Oak\Lib\X86\Debug
Devcore.lib1,092,93631-Dec-201406:26Public\Common\Oak\Lib\X86\Checked
Devcore.lib818,08031-Dec-201406:26Public\Common\Oak\Lib\Armv7\Retail
Devcore.lib1,165,10231-Dec-201406:26Public\Common\Oak\Lib\Armv7\Debug
Devcore.lib1,022,67031-Dec-201406:27Public\Common\Oak\Lib\Armv7\Checked


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbfix, kbsurveynew, kbexpertiseadvanced, atdownload, kb

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Article Info
Article ID : 3027632
Revision : 1
Created on : 1/7/2017
Published on : 1/28/2015
Exists online : False
Views : 218