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"XACT_E_CONNECTION_DOWN" error on SQL Server instances after you restart MS DTC in Windows 8 or Windows server 2012


View products that this article applies to.

Symptoms

This issue occurs on a Windows 8-based or Windows Server 2012-based SQL Server cluster. When you restart Microsoft Distributed Transaction Coordinator (MS DTC), SQL Server instances might not be able to reconnect to MS DTC successfully. Therefore, distributed transactions might fail with the error message until you restart the SQL server instances.

Note When this issue occurs, SQL Server does not log any message of losing connection.

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Cause

This issue occurs because the MS DTC proxy does not notify SQL Server that the connection is lost after MS DTC restarts. Therefore, SQL Server does not release a pointer and does not reinitialize the MSDTC proxy until it restarts.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

There is no prerequisite to apply this hotfix.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8 and Windows Server 2012 file information and notes

Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8/Windows Server 2012" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.



The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.


For all supported x86-based versions of Windows 8
File nameFile versionFile sizeDateTimePlatform
Msdtcprx.dll2001.12.10130.21339648,70431-Dec-201405:25x86
Xolehlp.dll2001.12.10130.1638451,71226-Jul-201203:20x86
For all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Msdtcprx.dll2001.12.10130.21339796,67231-Dec-201405:54x64
Xolehlp.dll2001.12.10130.1638461,95226-Jul-201203:08x64
Msdtcprx.dll2001.12.10130.21339648,70431-Dec-201405:25x86
Xolehlp.dll2001.12.10130.1638451,71226-Jul-201203:20x86

Additional file information

Additional file information for Windows 8 and for Windows Server 2012
Additional files for all supported x86-based versions of Windows 8
File propertyValue
File nameX86_01358eb2e98d83e9068a56e8eb0d79a7_31bf3856ad364e35_6.2.9200.21339_none_2e6380e5c424bd43.manifest
File versionNot applicable
File size702
Date (UTC)31-Dec-2014
Time (UTC)18:03
PlatformNot applicable
File nameX86_microsoft-windows-com-dtc-client_31bf3856ad364e35_6.2.9200.21339_none_4a628ec2a3a53caa.manifest
File versionNot applicable
File size6,835
Date (UTC)31-Dec-2014
Time (UTC)18:06
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
File propertyValue
File nameAmd64_44c682aa8334e20a3c5814bdb1f9eca7_31bf3856ad364e35_6.2.9200.21339_none_eab0158a0a912ff9.manifest
File versionNot applicable
File size1,054
Date (UTC)31-Dec-2014
Time (UTC)18:03
PlatformNot applicable
File nameAmd64_9d846df5c4fd9d6f52d165a5af28db85_31bf3856ad364e35_6.2.9200.21339_none_711a03648785602f.manifest
File versionNot applicable
File size706
Date (UTC)31-Dec-2014
Time (UTC)18:03
PlatformNot applicable
File nameAmd64_bb6cebed270e04ca6651996267149710_31bf3856ad364e35_6.2.9200.21339_none_271555f026190d44.manifest
File versionNot applicable
File size706
Date (UTC)31-Dec-2014
Time (UTC)18:03
PlatformNot applicable
File nameAmd64_microsoft-windows-com-dtc-client_31bf3856ad364e35_6.2.9200.21339_none_a6812a465c02ade0.manifest
File versionNot applicable
File size6,837
Date (UTC)31-Dec-2014
Time (UTC)18:03
PlatformNot applicable
File nameWow64_microsoft-windows-com-dtc-client_31bf3856ad364e35_6.2.9200.21339_none_b0d5d49890636fdb.manifest
File versionNot applicable
File size6,531
Date (UTC)31-Dec-2014
Time (UTC)18:03
PlatformNot applicable


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

See the terminology that Microsoft uses to describe software updates.

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

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Article Info
Article ID : 3024331
Revision : 1
Created on : 1/7/2017
Published on : 2/10/2015
Exists online : False
Views : 178