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Internet Explorer Quits When You Attempt to Browse Shockwave or Flash-enabled Site


Symptoms

When you attempt to browse a Macromedia Shockwave-enabled or Flash-enabled Web site, you may receive an error message similar to the following:
This program has performed an illegal operation
and will be shut down.

If the problem persists, contact the program
vendor.
When you click the Details button, the following information is displayed:
IEXPLORE caused an invalid page fault in
module DIRAPI.DLL at address
Internet Explorer may then quit.

NOTE: This behavior can also occur when you attempt to install Macromedia Shockwave or Flash.

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Cause

This issue can occur if the Dirapi.dll file is missing or damaged. This file is required by the Shockwave Player and Flash Player for proper operation.

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Resolution

To resolve this issue, remove and reinstall Macromedia Shockwave and Macromedia Flash. To do this, follow these steps.

Remove Macromedia Shockwave and Macromedia Flash

  1. Quit all running programs.
  2. On the taskbar, click Start, point to Settings, and then click Control Panel.
  3. In Control Panel, double-click Internet Options.
  4. In the Internet Options dialog box, on the General tab, under Temporary Internet files, click Settings.
  5. In the Settings dialog box, click View Objects.
  6. In the Downloaded Program Files dialog box, if a Shockwave-related item appears in the Program File list, right-click it, and then click Remove on the shortcut menu that appears.

    You receive the following message:
    Shockwave control will be removed permanently.
    Are you sure?
  7. Click Yes.
  8. Repeat steps 6 through 7 for each Shockwave-related entry in the list.
  9. On the File menu, click Close.
  10. In the Settings dialog box, click OK.
  11. In the Internet Properties dialog box, click OK, and then quit Control Panel.

Reinstall Macromedia Shockwave and Macromedia Flash

  1. Start Windows Explorer.
  2. Navigate to the following folder
    drive:\Windows\System\Macromed
    where drive is the drive on which Windows is installed, where Windows is the folder in which Windows is installed, and where System is the System folder in Windows 9x.
  3. Right-click the Macromed folder, and then click Delete on the shortcut menu that appears.
  4. On the Confirm Folder Delete message that appears, click Yes.
  5. Quit Windows Explorer, and then restart your computer.
  6. Reinstall Macromedia Shockwave and Macromedia Flash. The Macromedia Shockwave Player and the Macromedia Flash Player can be obtained from Macromedia at the following URL:
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

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Keywords: KB302396, kbprb, kbinvalidpagefault, kberrmsg, kb3rdparty

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Article Info
Article ID : 302396
Revision : 3
Created on : 6/19/2014
Published on : 6/19/2014
Exists online : False
Views : 171