Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Sysprep.exe process crashes when you use the SCVMM tool to create a VM template of a Windows Server 2012 image


View products that this article applies to.

Symptoms

This issue occurs if the following conditions are true:
  • You run the System Preparation (Sysprep) tool under a system account.
  • The Remote Desktop Services (RDS) role is enabled in Windows Server 2012.
When this issue occurs, you may be unable to create the virtual machine (VM) template.

Note SCVMM represents System Center Visual Machine Manager.

↑ Back to the top


Cause

This problem occurs because of an unmatched call on the CoUninitialize function in the Tssysprep.dll file.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

There is no prerequisite to apply this hotfix.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2012 file information and notes

Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8/Windows Server 2012" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Version Product Milestone Service branch
    6.2.920 0.17xxxWindows Server 2012RTMGDR
    6.2.920 0.21xxxWindows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Tssysprep.dll6.2.9200.1719360,41625-Nov-201406:45x64
Tssysprep.dll6.2.9200.2130960,41624-Nov-201423:38x64
Tssysprep.dll6.2.9200.1719356,83225-Nov-201404:57x86
Tssysprep.dll6.2.9200.2130956,83224-Nov-201423:39x86

Additional file information

Additional file information for Windows Server 2012
Additional files for all supported x64-based versions of Windows Server 2012
File propertyValue
File nameAmd64_1d7b0da2404ece22c40225e0c28b7526_31bf3856ad364e35_6.2.9200.21310_none_bb60ab6bb8c4cc83.manifest
File versionNot applicable
File size714
Date (UTC)26-Nov-2014
Time (UTC)00:18
PlatformNot applicable
File nameAmd64_7bbc03578009d2aa6b17666d93156710_31bf3856ad364e35_6.2.9200.17193_none_1eea987124714e7b.manifest
File versionNot applicable
File size1,072
Date (UTC)26-Nov-2014
Time (UTC)00:18
PlatformNot applicable
File nameAmd64_9a99a0a57545525c12c87dd0e8efd67a_31bf3856ad364e35_6.2.9200.17193_none_46c0764bcc939b29.manifest
File versionNot applicable
File size716
Date (UTC)26-Nov-2014
Time (UTC)00:18
PlatformNot applicable
File nameAmd64_9f4769688d93457dad721c8a2af93c3f_31bf3856ad364e35_6.2.9200.17193_none_06372d540c5852ca.manifest
File versionNot applicable
File size714
Date (UTC)26-Nov-2014
Time (UTC)00:18
PlatformNot applicable
File nameAmd64_aab2018b52a36e8d08cc8dc982c5660e_31bf3856ad364e35_6.2.9200.21310_none_f29e3d75f61127dd.manifest
File versionNot applicable
File size1,072
Date (UTC)26-Nov-2014
Time (UTC)00:18
PlatformNot applicable
File nameAmd64_c252e4fa9bc827f83f0128c4cd046d17_31bf3856ad364e35_6.2.9200.21310_none_2c80ab929bd438a4.manifest
File versionNot applicable
File size716
Date (UTC)26-Nov-2014
Time (UTC)00:18
PlatformNot applicable
File nameAmd64_microsoft-windows-t..nalservices-sysprep_31bf3856ad364e35_6.2.9200.17193_none_8a5752ebd20ef35d.manifest
File versionNot applicable
File size2,755
Date (UTC)25-Nov-2014
Time (UTC)07:28
PlatformNot applicable
File nameAmd64_microsoft-windows-t..nalservices-sysprep_31bf3856ad364e35_6.2.9200.21310_none_8b34701eeaee64c1.manifest
File versionNot applicable
File size2,755
Date (UTC)25-Nov-2014
Time (UTC)02:01
PlatformNot applicable
File nameX86_microsoft-windows-t..nalservices-sysprep_31bf3856ad364e35_6.2.9200.17193_none_2e38b76819b18227.manifest
File versionNot applicable
File size2,751
Date (UTC)25-Nov-2014
Time (UTC)05:21
PlatformNot applicable
File nameX86_microsoft-windows-t..nalservices-sysprep_31bf3856ad364e35_6.2.9200.21310_none_2f15d49b3290f38b.manifest
File versionNot applicable
File size2,751
Date (UTC)25-Nov-2014
Time (UTC)00:18
PlatformNot applicable


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

See the terminology that Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kb, kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced, kbautohotfix, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 3020396
Revision : 1
Created on : 1/7/2017
Published on : 2/11/2015
Exists online : False
Views : 204