Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Directory service does not start, event log shows error -510


View products that this article applies to.

This article was previously published under Q301505

↑ Back to the top


Symptoms

When you attempt to start the directory service, a pop-up window reports the following error:
Could not start the Microsoft Exchange Directory service on \\SERVERNAME Error 2140: An internal Windows NT error occurred.
The event log shows the following events:

Event ID: 109
Source: ESE97
Type: Information
MSExchangeDS (988) the database engine is replaying log file R:\LogFiles\DSAData\edb.log.

Event ID: 110
Source: ESE97
Type: Information
MSExchangeDS (988) the database engine has successfully completed recovery steps.

Event ID: 0
Source: ESE97
Type: Information
MSExchangeDS (988) -510

Event ID: 1166
Source: ESE97
Type: Information
Error -510 has occurred (internal ID 2030148). Contact Microsoft Technical Support for assistance.

Event ID: 1002
Source: ESE97
Type: Information
The Microsoft Exchange Server database (EDB) could not be initialized and returned error -510. Unrecoverable error, the directory can't continue.

EventID: 1166
Source: MSExchangeDS
Type: Information
Error -1811 has occurred (internal ID 2030148). Contact Microsoft Technical Support for assistance.

EventID: 1002
Source: MSExchangeDS
Type: Information
The Microsoft Exchange Server database (EDB) could not be initialized and returned error -1811. Unrecoverable error, the directory can't continue.

↑ Back to the top


Cause

Error -510 corresponds to JET_errLogWriteFail. The error can be caused by a corrupted Edb.log file.

↑ Back to the top


Workaround

To work around this issue, follow these steps:
  1. Backup your current database.
  2. Check whether Dir.edb is consistent by using eseutil /mh.
  3. Do one of the following:
    • If Dir.edb is consistent, remove all log files and start the directory service.

      -or-
    • If Dir.edb is inconsistent, restore from backup.
  4. When you restore from Online Backup, replay only transaction logs older than the corrupted one.
  5. When you restore from Offline Backup, empty the database and transaction log directories and restore only Dir.edb.

↑ Back to the top


Keywords: KB301505, kbprb

↑ Back to the top

Article Info
Article ID : 301505
Revision : 7
Created on : 2/28/2007
Published on : 2/28/2007
Exists online : False
Views : 304