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Hub Transport server cannot deliver messages when a database fails over to a cross-site DAG in Exchange Server 2010


View products that this article applies to.

Symptoms

When a database fails over to a cross-site database availability group (DAG), the Microsoft Exchange Server 2010 Hub Transport server cannot deliver messages to a mounted database, and the mailbox delivery queue on the Hub Transport server may begin growing with deliveries destined to the failed over database.

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Cause

This issue occurs because the LastMountedServer value and CurrentlyMountedServer values diverge for a long time.

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Workaround

To work around this issue, use one of the following methods:
  • Restart the Microsoft Exchange Transport Service on Hub Transport server. 
  • Open Exchange Management Shell, and then run the following cmdlet on the Hub Transport server:
    Retry-Queue submission-queue -resubmit:$true

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about the Retry-Queue cmdlet, see general information about Retry Queues.

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 3007794
Revision : 1
Created on : 1/7/2017
Published on : 12/9/2014
Exists online : False
Views : 202