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Site-to-site VPN interfaces cannot be removed in Windows Server 2012 R2 and a new site-to-site VPN cannot be established


View products that this article applies to.

This article describes an issue that occurs when you remove site-to-site VPN interfaces in Windows Server 2012 R2. A hotfix is available to resolve this issue. The hotfix has a prerequisite.

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Symptoms

When you run the Remove-VpnS2SInterface command to remove existing site-to-site VPN tunnel interfaces on a VPN server, this operation randomly fails. When this issue occurs, new site-to site VPN interfaces cannot be created on a VPN client that is running Windows 8.1 or Windows Server 2012 R2.

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Cause

This issue occurs because of a race condition between VPN interface removal and creation.

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Resolution

To resolve this issue, install the update rollup or the hotfix on both the VPN client and server.
Shall I choose hotfix or update rollup?
The update rollup fixes many other issues in addition to the issue that the hotfix fixes. We recommend that you use the update rollup. The update rollup is larger than the hotfix. Therefore, the update rollup takes longer to download.

Get the update rollup for Windows 8.1 or Windows Server 2012 R2

To resolve this issue, install the update rollup that is dated November 2014.

Get the November 2014 update rollup for Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2

Get the hotfix for Windows 8.1 or Windows Server 2012 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this update, you must have update 2919355 installed in Windows 8.1 or Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

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More Information

File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 and Windows Server 2012 R2 file information and notes

Important Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1/Windows Server 2012 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.3.960 0.17 xxxWindows 8.1 and Windows Server 2012 R2RTMGDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Iprtprio.dll6.3.9600.173969,21608-Oct-201406:43x86
Iprtrmgr.dll6.3.9600.17399285,18411-Oct-201400:33x86
Mprdim.dll6.3.9600.17396183,29608-Oct-201406:31x86
Rasmigplugin.dll7.2.9600.17396220,16008-Oct-201406:01x86
Rtm.dll6.3.9600.17396125,44008-Oct-201406:42x86
For all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Iprtprio.dll6.3.9600.1739611,26408-Oct-201407:29x64
Iprtrmgr.dll6.3.9600.17399323,07211-Oct-201400:34x64
Mprdim.dll6.3.9600.17396226,81608-Oct-201407:13x64
Rasmigplugin.dll7.2.9600.17396266,75208-Oct-201406:33x64
Rtm.dll6.3.9600.17396144,38408-Oct-201407:28x64

Additional file information

Additional file information for Windows 8.1 and for Windows Server 2012 R2
Additional files for all supported x86-based versions of Windows 8.1
File propertyValue
File nameX86_10312453864bb970107826b194efff2f_31bf3856ad364e35_6.3.9600.17399_none_46b3ad2ff98204a0.manifest
File versionNot applicable
File size697
Date (UTC)12-Oct-2014
Time (UTC)09:02
PlatformNot applicable
File nameX86_microsoft-windows-rasserver_31bf3856ad364e35_6.3.9600.17399_none_4043189c836a2a92.manifest
File versionNot applicable
File size79,380
Date (UTC)11-Oct-2014
Time (UTC)02:33
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File propertyValue
File nameAmd64_d5bf40c5820126309287a1755e2d43b6_31bf3856ad364e35_6.3.9600.17399_none_24850892f20608ca.manifest
File versionNot applicable
File size701
Date (UTC)12-Oct-2014
Time (UTC)09:02
PlatformNot applicable
File nameAmd64_f52eaa2d9752548b08a1abd12b9b0b4f_31bf3856ad364e35_6.3.9600.17399_none_c20b2384ac714b0b.manifest
File versionNot applicable
File size701
Date (UTC)12-Oct-2014
Time (UTC)09:02
PlatformNot applicable
File nameAmd64_microsoft-windows-rasserver_31bf3856ad364e35_6.3.9600.17399_none_9c61b4203bc79bc8.manifest
File versionNot applicable
File size79,386
Date (UTC)11-Oct-2014
Time (UTC)03:10
PlatformNot applicable
File nameWow64_microsoft-windows-rasserver_31bf3856ad364e35_6.3.9600.17399_none_a6b65e7270285dc3.manifest
File versionNot applicable
File size73,348
Date (UTC)11-Oct-2014
Time (UTC)02:33
PlatformNot applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

See the terminology that Microsoft uses to describe software updates.

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced, kbautohotfix, kbhotfixserver, kb

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Article Info
Article ID : 3004538
Revision : 1
Created on : 1/7/2017
Published on : 1/6/2015
Exists online : False
Views : 205