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Print jobs fail in Windows 7 and Windows Server 2008 R2


View products that this article applies to.

Symptoms

When you try to print on a system that's running Windows 7 or Windows Server 2008 R2, the print job fails.

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Cause

This problem occurs when the DependentFiles registry key for the driver that's used by the printer is overwritten by a NULL string.

The DependentFiles registry key is located under the following subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\<architecture>\Drivers\Version-3\<driver_name>
Note The <driver_name> placeholder represents the name of the driver in question.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information and notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductSR_LevelService branch
    6.1.760
    1.
    17xxx
    Windows 7 and Windows Server 2008 R2SP1GDR
    6.1.760
    1.
    22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7601.22816777,21622-Sep-201401:41x86
Winprint.dll6.1.7601.1751430,20820-Nov-201012:21x86
For all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7601.22816967,16822-Sep-201402:05x64
Winprint.dll6.1.7601.1751439,42420-Nov-201013:27x64
Localspl.dll6.1.7601.22816777,21622-Sep-201401:41x86
Winprint.dll6.1.7601.1751430,20820-Nov-201012:21x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7601.228162,081,28022-Sep-201401:24IA-64
Winprint.dll6.1.7601.1751490,62420-Nov-201010:28IA-64

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_728d524815737c24fcc21f0e88806092_31bf3856ad364e35_6.1.7601.22816_none_f4f0564e77ae045e.manifest
File versionNot Applicable
File size718
Date (UTC)22-Sep-2014
Time (UTC)18:42
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameX86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22816_none_32ae524a0a0c184d.manifest
File versionNot Applicable
File size4,844
Date (UTC)22-Sep-2014
Time (UTC)18:55
SHA-1 hashNot Applicable
MD5 hashNot Applicable
Additional files for all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameAmd64_728d524815737c24fcc21f0e88806092_31bf3856ad364e35_6.1.7601.22816_none_510ef1d2300b7594.manifest
File versionNot Applicable
File size720
Date (UTC)22-Sep-2014
Time (UTC)18:42
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameAmd64_fdbd0839a6782b689f5c4e3919eecfb0_31bf3856ad364e35_6.1.7601.22816_none_b16a6d6fddf8423a.manifest
File versionNot Applicable
File size722
Date (UTC)22-Sep-2014
Time (UTC)18:42
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameAmd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22816_none_8eccedcdc2698983.manifest
File versionNot Applicable
File size4,845
Date (UTC)22-Sep-2014
Time (UTC)19:00
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameX86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22816_none_32ae524a0a0c184d.manifest
File versionNot Applicable
File size4,844
Date (UTC)22-Sep-2014
Time (UTC)19:00
SHA-1 hashNot Applicable
MD5 hashNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_abd3baa441627b745808780776ce9249_31bf3856ad364e35_6.1.7601.22816_none_423010333a6e86fc.manifest
File versionNot Applicable
File size720
Date (UTC)22-Sep-2014
Time (UTC)18:42
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameIa64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22816_none_32aff6400a0a2149.manifest
File versionNot Applicable
File size4,844
Date (UTC)22-Sep-2014
Time (UTC)18:42
SHA-1 hashNot Applicable
MD5 hashNot Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 3001232
Revision : 1
Created on : 1/7/2017
Published on : 11/13/2014
Exists online : False
Views : 189